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1 ARM Keil MDK 软件 

1.1 软件安装 

请参考 ARM Keil MDK（V5.26 及以上版本）网站提供的 Getting Started 

with MDK。 

1.2 工程模板 

使用 ARM Keil MDK 软件进行 Gowin_EMPU(GW1NS-4C)软件编程设

计，需要创建工程、配置编译选项、编写代码、编译、下载和在线调试。 

1.2.1 创建工程 

双击打开 ARM Keil MDK 软件，选择菜单栏“Project > New uVision 

Project…”，创建工程，如图 1-1 所示。 

图 1-1 创建工程 

 

https://armkeil.blob.core.windows.net/product/gs_MDK5_4_en.pdf
https://armkeil.blob.core.windows.net/product/gs_MDK5_4_en.pdf
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1.2.2 配置编译选项 

配置器件 

Gowin_EMPU(GW1NS-4C)内置 ARM Cortex-M3 MCU 内核，所以器

件类型配置为“ARM Cortex M3 > ARMCM3”，如图 1-2 所示。 

图 1-2 配置器件 

 

 

配置 ROM 和 RAM 

配置 ROM（指令存储器，FLASH）和 RAM（数据存储器，SRAM）的

起始地址和 Size，如图 1-3 所示。 

ROM 配置： 

 起始地址：0x00000000 

 Size：0x8000（32KB） 

RAM 配置： 

 起始地址：0x20000000 

 Size：与高云半导体云源软件的 IP Core Generator 工具中

Gowin_EMPU(GW1NS-4C) IP Core 的 SRAM Size 配置保持一致，可以

配置为 2KB、4KB、8KB 或 16KB 
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图 1-3 配置 ROM 和 RAM 

 

 

配置输出文件格式 

Gowin_EMPU(GW1NS-4C)软件编程设计需要产生软件编程设计

Binary 文件，所以需要将 axf 文件格式转换为 Binary 文件格式。 

User 命令行选项中，使用格式转换工具 fromelf 转换输出文件 axf 格式

为 bin 格式，调用方法如图 1-4 所示。 

fromelf 格式转换命令为：fromelf.exe --bin -o bin-file axf-file。例如，

C:\Keil_v5\ARM\ARMCC\bin\fromelf.exe --bin -o led.bin .\Objects\led.axf。 

格式转换工具 fromelf 的路径，请根据用户本地 ARM Keil MDK 安装路

径进行修改。 
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图 1-4 配置输出文件格式 

 

 

配置头文件路径 

配置 C 代码头文件路径，编译过程中用来调用不同路径的 C 头文件，

配置如图 1-5 所示。 

例如， 

 "..\..\..\library\libraries\cmsis\cm3\core_support\mdk" 

 "..\..\..\library\libraries\cmsis\cm3\device_support" 

 "..\..\..\library\libraries\drivers\inc" 

 "..\..\..\library\middlewares\delay" 

 "..\..\..\library\middlewares\gpio" 

 "..\inc" 
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图 1-5 配置头文件路径 

 

 

配置 Flash 选项 

如果需要在线调试，请关闭“Utilities > Update Target before Debugging”

选项，如图 1-6 所示。 

图 1-6 配置 Flash 选项 
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1.2.3 编译 

完成代码编写和选项配置后，单击工具栏“Build”（ ）或“Rebuild”

（ ），或菜单栏“Project > Build Target”或“Project > Rebuild all target 

files”，编译产生软件编程设计 Binary 文件，如图 1-7 所示。 

图 1-7 编译 

 

1.2.4 下载 

使用云源软件的下载工具Programmer，下载软件编程设计Binary文件。 

在云源软件中或安装路径下，打开下载工具 Programmer。 

单击 Programmer 菜单栏“Edit > Configure Device”或工具栏

“Configure Device”（ ），打开 Device configuration。 

如果选用 FPGA 产品 GW1NS-4C 或 GW1NSR-4C，下载选项配置，如

图 1-8 所示。 

 Access Mode 下拉列表，选择“MCU Mode”选项。 

 Operation 下拉列表，选择“Firmware Erase, Program”选项或“Firmware 

Erase, Program, Verify”选项。 
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图 1-8 FPGA 产品 GW1NS-4C/GW1NSR-4C 下载选项配置 

 

 

如果选用 FPGA 产品 GW1NSER-4C，下载选项配置，如图 1-9 所示。 

 Access Mode 下拉列表，选择“SecureFPGA Mode”选项。 

 Operation 下拉列表，选择“Firmware Erase, Program Securely”选项。 

图 1-9 FPGA 产品 GW1NSER-4C 下载选项配置 
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 “FW/MCU/Binary Input Options > Firmware/Binary File”选项，导入软

件编程设计 Binary 文件。 

 单击“Save”，完成下载选项配置。 

注！ 

“Programming Options > File name”选项，导入硬件设计码流文件，请参考 IPUG932, 

Gowin_EMPU(GW1NS-4C)硬件设计参考手册。 

完成 Device configuration 后，单击 Programmer 工具栏 

“Program/Configure”（ ），完成软件编程设计 Binary 文件和硬件设计码

流文件的下载。 

1.2.5 在线调试 

完成软件编程设计 Binary 文件和硬件设计码流文件的下载后，如果用户

软件设计出现问题，可以连接 U-LINK 或 J-LINK 等仿真器在线调试。 

软件单步调试流程包括： 

 MCU JTAG 模式切换 

 MCU JTAG 接口切换 

 配置软件调试选项 

 连接调试仿真器 

 启动软件调试 

MCU JTAG 模式切换 

使用下载工具 Programmer，将 MCU JTAG 模式，由下载模式切换到调

试模式。 

在云源软件中或安装路径下，打开下载工具 Programmer。 

单击 Programmer 菜单栏“Edit > Configure Device”或工具栏 

“Configure Device”（ ），打开 Device configuration。 

如果选用 FPGA 产品 GW1NS-4C 或 GW1NSR-4C，MCU JTAG 模式

切换配置，如图 1-10 所示。 

 Access Mode 下拉列表，选择“MCU Mode”选项。 

 Operation 下拉列表，选择“Connect to JTAG of MCU”选项。 

http://cdn.gowinsemi.com.cn/IPUG932.pdf
http://cdn.gowinsemi.com.cn/IPUG932.pdf
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图 1-10 FPGA 产品 GW1NS-4C/GW1NSR-4C MCU JTAG 模式切换配置 

 

 

如果选用 FPGA 产品 GW1NSER-4C，MCU JTAG 模式切换配置，如

图 1-11 所示。 

 Access Mode 下拉列表，选择“SecureFPGA Mode”选项。 

 Operation 下拉列表，选择“Connect to JTAG of MCU”选项。 

图 1-11 FPGA 产品 GW1NSER-4C MCU JTAG 模式切换配置 

 

 

 单击“Save”，完成 MCU JTAG 模式切换配置。 

完成 Device configuration 后，单击 Programmer 工具栏 

“Program/Configure”（ ），完成 MCU JTAG 模式切换。 

MCU JTAG 接口切换 

例如 DK-START-GW1NSR4C-QN48G V1.1 开发板，手动将开发板上

SW3、SW4、SW5、SW6 拨码开关（JTAG 接口 TCK、TDO、TDI 和 TMS）

由“FT232”（Download）切换为“J-LINK”（Debug）。 

注！ 
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 在 MCU JTAG 模式切换和 MCU JTAG 接口切换过程中，必须保持开发板上电状态，

不可断电。 

 如果中途开发板断电，重新上电后自动还原为 MCU JTAG 下载模式。 

配置软件调试选项 

ARM Keil MDK 软件中，单击工具栏 Options for Target…“ ”，打开

Options for Target，配置“Debug”选项。 

 配置仿真器类型 

单击 Debug 仿真器类型下拉列表，配置所用仿真器类型，如图 1-12 所

示。 

- U-LINK 仿真器 

如果选择使用 U-LINK 仿真器，则选择“ULNK2/ME Cortex 

Debugger”。 

- J-LINK 仿真器 

如果选择使用 J-LINK 仿真器，则选择“J-LINK/J-TRACE Cortex”。 

图 1-12 配置仿真器类型 

 

 

 配置调试接口类型  

单击 Settings，如果选用 J-LINK，则打开 Cortex JLink/JTrace Target 

Driver Setup；如果选用 U-LINK，则打开 ULINK2/ME Cortex-M Target 

Driver Setup。 

例如选用 J-LINK 仿真器，如图 1-13 所示。 



1 ARM Keil MDK 软件 1.2 工程模板 

 

IPUG928-2.0 11(31) 

 

- JTAG 调试接口 

Gowin_EMPU(GW1NS-4C)支持 JTAG 调试接口，配置 Port 选项为

“JTAG”。 

- SW 调试接口 

Gowin_EMPU(GW1NS-4C)不支持 SW 调试接口，请不要选用 SW

调试接口。 

图 1-13 配置调试接口类型 

 

 

Download Options 配置选项，请关闭“Verify Code Download”选项和

“Download to Flash”选项。 

如果调试选项配置成功，在 MCU JTAG 模式切换、MCU JTAG 接口切

换以及连接仿真器后，JTAG Device Chain 可以正确显示

Gowin_EMPU(GW1NS-4C)的 IDCODE、Device Name 等信息。 

启动软件调试 

完成软件调试选项配置后，连接 U-LINK 或 J-LINK 调试仿真器。 

单击工具栏 Debug“ ”，或菜单栏“Debug > Start/Stop Debug 

Session”，进入软件调试状态。 

可以执行断点设置、单步调试、复位和运行等操作，如图 1-14 所示。 
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图 1-14 启动软件调试 

 

1.3 参考设计 

Gowin_EMPU(GW1NS-4C)支持 ARM Keil MDK（已测试软件版本：

V5.26）软件的参考设计，通过此链接获取如下参考设计：

cdn.gowinsemi.com.cn/Gowin_EMPU(GW1NS-4C)_V2.0.zip 

…\ref_design\MCU_RefDesign\MDK_RefDesign\cm3_demo、

cm3_freertos、cm3_rtthread_nano、cm3_ucos_iii 

https://cdn.gowinsemi.com.cn/Gowin_EMPU(GW1NS-4C)_V2.0.zip
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2 GMD 软件 

2.1 软件安装 

高云半导体网站提供 GMD 软件安装包下载

http://www.gowinsemi.com.cn/prodshow.aspx。 

注！ 

GMD 软件安装与配置，请参考 SUG549， GOWIN MCU Designer 用户指南。 

2.2 工程模板 

使用 GMD 软件进行 Gowin_EMPU(GW1NS-4C)软件编程设计，需要创

建工程、配置编译选项、编写代码、编译、下载和在线调试。 

2.2.1 创建工程 

创建工程 

选择工具栏“New”（ ）或菜单栏“File > New > C Project”，如图

2-1 所示。 

 建立项目名称和项目位置； 

 选择项目类型 Empty Project； 

 选择编译工具链 ARM Cross GCC。 

http://www.gowinsemi.com.cn/prodshow.aspx
http://cdn.gowinsemi.com.cn/SUG549.pdf
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图 2-1 创建工程 

 

 

选择平台配置类型 

选择平台配置类型“Debug”和“Release”，如图 2-2 所示。 

图 2-2 选择平台类型配置 
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选择工具链和路径 

选择交叉编译工具链 arm-none-eabi-gcc 及其所在路径，推荐默认配置

Toolchain name 和 Toolchain path，如图 2-3 所示。 

图 2-3 选择工具链和路径 

 

 

建立项目工程 

完成工程创建后，在 Project Explorer 视图中选择新建的项目工程，添

加工程结构和代码，导入软件编程设计。 

在 Project Explorer 视图中选择当前工程，右键选择“Refresh”选项，

可以自动更新当前项目工程的结构和代码。 

2.2.2 配置选项 

Project Explorer 视图中，选择当前工程，右键选择“Properties > C/C++ 

Build > Settings”，配置当前工程的参数选项。 

配置 Target Processor 

配置“Target Processor > ARM family”选项，该选项配置为“cortex-m3”，

如图 2-4 所示。 
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图 2-4 配置 Target Processor 

 

 

配置 GNU ARM Cross Assembler > Preprocessor 

配置“GNU ARM Cross Assembler > Preprocessor > Defined symbols 

(-D)”选项，该选项配置为“__STARTUP_CLEAR_BSS”，如图 2-5 所示。 
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图 2-5 配置 GNU ARM Cross Assembler > Preprocessor 

 

 

配置 GNU ARM Cross C Compiler > Includes 

配置“GNU ARM Cross C Compiler > Includes > Include paths (-I)”选

项，该选项配置为当前工程 C 头文件引用路径，如图 2-6 所示。 
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图 2-6 配置 GNU ARM Cross C Compiler > Includes 

 

 

例如软件编程参考设计 GMD_RefDesign\cm3_demo，C 头文件引用路

径配置，如下所示。 

 "${workspace_loc:/${ProjName}/src/library/libraries/cmsis/cm3/device_
support}" 

 "${workspace_loc:/${ProjName}/src/library/libraries/cmsis/cm3/core_su
pport/gmd}" 

 "${workspace_loc:/${ProjName}/src/library/libraries/drivers/inc}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/delay}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/dmm}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/gpio}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/hyper_ram}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/psram}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/spi_flash}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/uart}" 

 "${workspace_loc:/${ProjName}/src/project}" 



2 GMD 软件 2.2 工程模板 

 

IPUG928-2.0 19(31) 

 

配置 GNU ARM Cross C Linker 

配置“GNU ARM Cross C Linker > General > Script files (-T)”选项，

该选项配置“gw1ns4c_flash.ld”作为 GMD Flash 链接器，如图 2-7 所示。 

图 2-7 配置 GNU ARM Cross C Linker 选项 

 

 

例如软件编程参考设计 GMD_RefDesign\cm3_demo，Flash 链接器配

置，如下所示： 

"${workspace_loc:/${ProjName}/src/library/libraries/cmsis/cm3/device

_support/startup/gmd/linker/gw1ns4c_flash.ld}" 

配置 GNU ARM Cross Create Flash Image 

配置“Cross ARM GNU Create Flash Image > General > Output file 

format (-O)”选项，该选项配置为“Raw binary”，产生软件编程设计 Binary

文件，如图 2-8 所示。 
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图 2-8 配置 GNU ARM Cross Create Flash Image 

 

 

配置 Devices 

配置“Devices > Device selection”选项，该选项配置为“ARM Cortex 

M3 > ARMCM3”，如图 2-9 所示。 
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图 2-9 配置 Devices 

 

2.2.3 编译 

完成工程选项配置和代码编写后，编译当前工程，单击工具栏 Build“ ” 

或 Build All “ ”，或菜单栏“Project > Build Project”或“Project > Build 

All”，编译产生软件编程设计 Binary 文件，如图 2-10 所示。 



2 GMD 软件 2.2 工程模板 

 

IPUG928-2.0 22(31) 

 

图 2-10 编译 

 

2.2.4 下载 

使用下载工具 Programmer，下载软件编程设计 Binary 文件。 

单击 GMD 软件菜单栏“Run > Programmer”或工具栏 Programmer 

“ ”，打开下载工具 Programmer，如图 2-11 所示。 
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图 2-11 下载工具 Programmer 

 

 

单击下载工具 Programmer 菜单栏“Edit > Configure Device”或工具

栏 Configure Device“ ”，打开 Device configuration。 

如果选用 FPGA 产品 GW1NS-4C 或 GW1NSR-4C，下载选项配置，如

图 2-12 所示。 

 Access Mode 下拉列表，选择“MCU Mode”选项。 

 Operation 下拉列表，选择“Firmware Erase, Program”选项或“Firmware 

Erase, Program, Verify”选项。 
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图 2-12 FPGA 产品 GW1NS-4C/GW1NSR-4C 下载选项配置 

 

 

如果选用 FPGA 产品 GW1NSER-4C，下载选项配置，如图 2-12 所示。 

 Access Mode 下拉列表，选择“SecureFPGA Mode”选项。 

 Operation 下拉列表，选择“Firmware Erase, Program Securely”选项。 

图 2-13 FPGA 产品 GW1NSER-4C 下载选项配置 
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 “FW/MCU/Binary Input Options > Firmware/Binary File”选项，导入软

件编程设计 Binary 文件。 

 单击“Save”，完成下载选项配置。 

注！ 

“Programming Options > File name”选项，导入硬件设计码流文件，请参考 IPUG932, 

Gowin_EMPU(GW1NS-4C)硬件设计参考手册。 

完成 Device configuration 后，单击 Programmer 工具栏 

“Program/Configure”（ ），完成软件编程设计 Binary 文件和硬件设计码

流文件的下载。 

2.2.5 在线调试 

完成软件编程设计 Binary 文件和硬件设计码流文件的下载后，如果用户

软件设计出现问题，可以连接 J-LINK 仿真器，在线调试当前 MCU 软件编程

设计（在线调试的 MCU 软件编程设计必须与下载到芯片中的 MCU 软件编

程设计保持一致）。 

软件单步调试流程，包括： 

 配置软件调试等级 

 配置软件调试选项 

 MCU JTAG 模式切换 

 MCU JTAG 接口切换 

 连接调试仿真器 

 启动软件调试 

配置软件调试等级 

Project Explorer 视图中，选择当前调试项目工程的“Properties > C/C++ 

Build > Settings > Tool Settings > Debugging > Debug level”选项，推荐配

置调试等级为 Default(-g)或 Maximum(-g3)，如图 2-14 所示。 

http://cdn.gowinsemi.com.cn/IPUG932.pdf
http://cdn.gowinsemi.com.cn/IPUG932.pdf


2 GMD 软件 2.2 工程模板 

 

IPUG928-2.0 26(31) 

 

图 2-14 配置软件调试等级 

 

 

配置软件调试选项 

选择菜单栏“Run > Debug Configurations > GDB SEGGER J-Link 

Debugging”，右键选择“New”选项，建立当前工程的软件调试配置选项，

如图 2-15 所示。 
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图 2-15 建立软件调试配置选项 

 

 

选择已建立的调试选项。 

1. 选择“Main”选项，配置当前调试工程的 Project 和 C/C++ Application

等选项，如图 2-16 所示。 

图 2-16 配置 Main 选项 

 

 

2. 选择“Debugger”选项，配置当前调试工程的 J-Link 和 GDB 等选项，
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如图 2-17 所示。 

例如: 

 Device name：Cortex-M3 

 Endianness：Little 

 Connection：USB 

 Interface：JTAG 

 Connect to running target：Close 

 Initial speed：Fixed 1000KHz 

 GDB port：2331 

 SWO port：2332 

 Telnet：2333 

 Verify downloads：Open 

 Initialize registers on start：Open 

 Local host only：Open 

 Other options：-singlerun –strict –timeout 0 –nogui 

 Command：set mem inaccessible-by-default off 

Gowin_EMPU(GW1NS-4C)支持 JTAG 调试接口，不支持 SWD 调试接

口。 

禁用 Connect to running target 选项。 
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图 2-17 配置 Debugger 选项 

 

 

MCU JTAG 模式切换 

使用下载工具 Programmer，将 Gowin_EMPU(GW1NS-4C)的 MCU 

JTAG 模式，由下载模式切换到调试模式。 

单击 GMD 软件菜单栏“Run > Programmer”或工具栏 Programmer

“ ”，打开下载工具 Programmer，如图 2-11 所示。 

单击 Programmer 菜单栏“Edit > Configure Device”或工具栏 

“Configure Device”（ ），打开 Device configuration。 

如果选用 FPGA 产品 GW1NS-4C 或 GW1NSR-4C，MCU JTAG 模式

切换配置，如图 2-18 所示。 

 Access Mode 下拉列表，选择“MCU Mode”选项。 

 Operation 下拉列表，选择“Connect to JTAG of MCU”选项。 
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图 2-18 FPGA 产品 GW1NS-4C/GW1NSR-4C MCU JTAG 模式切换配置 

 

 

如果选用 FPGA 产品 GW1NSER-4C，MCU JTAG 模式切换配置，如

图 2-19 所示。 

 Access Mode 下拉列表，选择“SecureFPGA Mode”选项。 

 Operation 下拉列表，选择“Connect to JTAG of MCU”选项。 

图 2-19 FPGA 产品 GW1NSER-4C MCU JTAG 模式切换配置 

 

 

 单击“Save”，完成 MCU JTAG 模式切换配置。  

完成 Device configuration 后，单击 Programmer 工具栏 

“Program/Configure”（ ），完成 MCU JTAG 模式切换。 

MCU JTAG 接口切换 

例如 DK-START-GW1NSR4C-QN48G V1.1 开发板，手动将开发板上

SW3、SW4、SW5、SW6 拨码开关（JTAG 接口 TCK、TDO、TDI 和 TMS）

由“FT232”（Download）切换为“J-LINK”（Debug）。 

注！ 
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 在 MCU JTAG 模式切换和 MCU JTAG 接口切换过程中，必须保持开发板上电状态，

不可断电。 

 如果中途开发板断电，重新上电后自动还原为 MCU JTAG 下载模式。 

启动软件调试 

连接 J-LINK 仿真器。 

单击工具栏 Debug“ ”，进入调试状态，可以执行断点设置、单步

调试、复位和运行等操作，如图 2-20 所示。 

图 2-20 启动软件调试 

 

2.3 参考设计 

Gowin_EMPU(GW1NS-4C)支持 GMD（已测试软件版本：V1.2）软件

的参考设计，通过此链接获取如下参考设计：

cdn.gowinsemi.com.cn/Gowin_EMPU(GW1NS-4C)_V2.0.zip 

…\ref_design\MCU_RefDesign\GMD_RefDesign\cm3_demo、

cm3_freertos、cm3_rtthread_nano、cm3_ucos_iii 

https://cdn.gowinsemi.com.cn/Gowin_EMPU(GW1NS-4C)_V2.0.zip
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