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1 ARM Keil MDK 

1.1 Software Installation 

For the detailed information, please refer to Getting Started with MDK 

(V5.26 and above) provided by ARM Keil MDK website. 

1.2 Project Template 

ARM Keil MDK can be used for Gowin_EMPU(GW1NS-4C) software 

programming. The steps include project creation, configuration, coding, 

build, download and debug. 

1.2.1 Create a New Project 

Open ARM Keil MDK and select "Project > New uVision Project…" to 

create a new project, as shown in Figure 1-1. 

https://armkeil.blob.core.windows.net/product/gs_MDK5_4_en.pdf
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Figure 1-1 Create a New Project 

 

1.2.2 Configuration Option 

Device Configuration 

ARM Cortex-M3 is embedded in Gowin_EMPU(GW1NS-4C), and the 

device is configured as "ARM Cortex M3 > ARMCM3", as shown in Figure 

1-2. 

Figure 1-2 Device Configuration 
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ROM and RAM Configuration 

Configure the start address and size of Flash for instructions and 

SRAM for data, as shown in Figure 1-3. 

ROM Configuration 

 Start Address: 0x00000000 

 Size: 0x8000 (32KB) 

RAM Configuration 

 Start Address: 0x20000000 

 Size: Consistent with the SRAM Size configuration of the 
Gowin_EMPU(GW1NS-4C) IP Core in the IP Core Generator tool of 
Gowin Software, which can be configured as 2KB, 4KB, 8KB, or 16KB. 

Figure 1-3 ROM and RAM Configuration 

 

 

Output File Format Configuration 

Gowin_EMPU (GW1NS-4C) software programming design requires 

the generation of a software programming binary file. Therefore, it is 

necessary to convert the axf format to the binary format. 

In the user command line option, convert the format of output file from 

axf to bin using fromelf, the output file format conversion tool. The call 
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method is as shown in Figure 1-4. 

The format conversion command of fromelf is: fromelf.exe --bin -o 

bin-file axf-file. For example, C:\Keil_v5\ARM\ARMCC\bin\fromelf.exe --bin 

-o led.bin .\Objects\led.axf. 

The path of fromelf should be modified according to the user's local 

installation path of ARM Keil MDK. 

Figure 1-4 Output File Format Configuration 

 

 

Header File Path Configuration 

Configure C code header file path and different header file C paths are 

called during building, as shown in Figure 1-5. 

For example: 

 "..\..\..\library\libraries\cmsis\cm3\core_support\mdk" 

 "..\..\..\library\libraries\cmsis\cm3\device_support" 

 "..\..\..\library\libraries\drivers\inc" 

 "..\..\..\library\middlewares\delay" 

 "..\..\..\library\middlewares\gpio" 
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 "..\inc" 

Figure 1-5 Header File Path Configuration 

 

 

Flash Configuration 

If online debugging is required, disable "Utilities > Update Target 

before Debugging" option as shown in Figure 1-6. 
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Figure 1-6 Flash Configuration 

 

1.2.3 Build 

After encoding and configuration, click "Build" ( ) or "Rebuild" ( ) 

on tool bar, or click "Project > Build Targets" or "Project > Rebuild All Target 

Files" on the menu bar to generate software programming Binary File, as 

shown in Figure 1-7. 
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Figure 1-7 Build 

 

1.2.4 Download 

Download the programming Binary file using Gowin Programmer. 

Open Programmer in Gowin Software or under the installation path. 

Click "Edit > Configure Device" on the menu bar or "Configure Device 

" ( ) on the tool bar to open the "Device configuration". 

If FPGA product GW1NS-4C or GW1NSR-4C is selected, 

configuration options are as shown in Figure 1-8.. 

 Select "MCU Mode" in "Access Mode" drop-down list. 

 Select "Firmware Erase, Program" or "Firmware Erase, Program, 
Verify" in "Operation" drop-down list. 
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Figure 1-8 Configuration Options for GW1NS-4C or GW1NSR-4C 

 

 

If FPGA product GW1NSER-4C is selected, configuration options are 

as shown in Figure 1-9. 

 Select "SecureFPGA Mode" in "Access Mode" drop-down list; 

 Select "Firmware Erase, Program Securely" in "Operation" drop-down 
list. 
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Figure 1-9 Configuration Options for GW1NSER-4C 

 

 

 Import software programming Binary file in "FW/MCU/Binary Input 
Options > Firmware/Binary File". 

 Click "Save" to complete the configuration. 

Note! 

Import hardware design bitstream in "Programming Options > File name", please refer to 

IPUG932, Gowin_EMPU(GW1NS-4C) Hardware Design Reference Manual. 

After device configuration, click Program/Configure ( ) on the 

Programmer toolbar to complete the download of the software 

programming Binary file and the hardware bitstream file. 

1.2.5 On-line Debug 

After completing the download of the software programming Binary file 

and the hardware bitstream file, if there are any design issues, you can use 

U-LINK and J-LINK to debug online. 

The single-step debug flow includes: 

 Switch MCU JTAG mode 

 Switch MCU JTAG interface 

 Configure software debug 

 Connect debug emulator 

http://cdn.gowinsemi.com.cn/IPUG932E.pdf
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 Start software debug 

MCU JTAG Mode Switch 

Switch JTAG mode from the downloading to debug mode using 

Programmer. 

Open Programmer in Gowin Software or under the installation path. 

Click "Edit > Configure Device" on the menu bar or "Configure Device 

" ( ) on the tool bar to open the "Device configuration". 

If FPGA product GW1NS-4C or GW1NSR-4C is selected, MCU JTAG 

mode configuration options are as shown in Figure 1-10. 

 Select "MCU Mode" in "Access Mode" drop-down list. 

 Select "Connect to JTAG of MCU" in "Operation" drop-down list. 

Figure 1-10 MCU JTAG Mode Configuration for GW1NS-4C or GW1NSR-4C 

 
 

If FPGA product GW1NSER-4C is selected, MCU JTAG mode 

configuration options are as shown in Figure 1-11. 

 Select "SecureFPGA Mode" in "Access Mode" drop-down list. 

 Select "Connect to JTAG of MCU" in "Operation" drop-down list. 
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Figure 1-11 MCU JTAG Mode Configuration for GW1NSER-4C 

 

 

 Click "Save" to complete the configuration. 

After device configuration, click "Program/Configure" ( ) in the 

Programmer tool bar to complete MCU JTAG mode switch. 

MCU JTAG Interface Switch 

Taking DK-START-GW1NSR4C-QN48G V1.1 for an instance, switch 

SW3, SW4, SW5, SW6 (TCK, TDO, TDI, and TMS of JTAG interface) on 

the development board from "FT232" (Download） to "J-LINK" (debug). 

Note! 

 The development board must be kept on power in MCU JTAG mode and interface 

switch. 

 If the development board powers off in the process, it will restore to MCU JTAG 

download mode automatically after power on. 

Software Debug Configuration Option 

In the ARM Keil MDK software, click "Options for Target..." ( ) on the 

tool bar to configure "Debug" option. 

 Emulator Type Configuration 
Click the Debug emulator type drop-down list to configure type, as 
shown in Figure 1-12. 

- U-LINK Emulator 
If the U-LINK emulator is used, select "ULNK2/ME Cortex 
Debugger". 

- J-LINK Emulator  
If the J-LINK emulator is used, select "J-LINK/J-TRACE Cortex". 
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Figure 1-12 Emulator Type Configuration 

 

 

 Debug Interface Type Configuration 

Click Settings and open Cortex JLink/JTrace Target Driver Setup if 

J-LINK is selected, or ULINK2/ME Cortex-M Target Driver Setup if 

U-LINK is selected. 

For example, the J-LINK emulator is selected, as shown in Figure 

1-13. 

- JTAG Debug Interface   
Gowin_EMPU(GW1NS-4C) supports JTAG debug interface and 
configure Port to "JTAG". 

- SW Debug Interface 
Gowin_EMPU(GW1NS-4C) does not support SW debug interface, 
so do not select this one. 
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Figure 1-13 Debug Interface Type Configuration 

 

 

Disable "Verify Code Download" and "Download to Flash" options in 

"Download Options". 

If the debug options configuration is successful, after switching MCU 

JTAG mode and interface and connecting the emulator, the IDCODE, 

Device Name and other information of Gowin_EMPU(GW1NS-4C) will be 

displayed in the JTAG Device Chain". 

Start Software Debug 

Connect the U-LINK or J-LINK debug emulator after software debug 

configuration. 

Click the Debug " " on the tool bar, or click "Debug > Start/Stop 

Debug Session" on the menu bar to start software debug. 

You can perform operations of breakpoint setting, single-step debug, 

reset, run, etc. as shown in Figure 1-14. 
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Figure 1-14 Start Software Debugging 

 

1.3 Reference Design 

Gowin_EMPU (GW1NS-4C) supports the reference design in ARM 

Keil MDK (tested software version V5.26), and you can click here to get the 

following reference design:  

…\ref_design\MCU_RefDesign\MDK_RefDesign\cm3_demo、

cm3_freertos、cm3_rtthread_nano、cm3_ucos_iii 

https://cdn.gowinsemi.com.cn/Gowin_EMPU(GW1NS-4C)_V2.0.zip
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2 GOWIN MCU Designer 

2.1 Software Installation 

The installation package of GMD is available at website 

http://www.gowinsemi.com.cn/prodshow.aspx. 

Note! 

For the details of GMD, please refer to SUG549, GOWIN MCU Designer User Guide. 

2.2 Project Template 

GMD can be used for Gowin_EMPU(GW1NS-4C) software 

programming. The steps include project creation, configuration, coding, 

building, download and debug. 

2.2.1 Create a New Project 

Create a New Project 

Select "New" ( ) on the tool bar, or click "File > New > C Project" on 

the menu bar, as shown in Figure 2-1. 

 Create a project name and location; 

 Select the "Empty Project" type; 

 Select the "Cross ARM GCC" build toolchain. 

http://www.gowinsemi.com.cn/prodshow.aspx
http://cdn.gowinsemi.com.cn/SUG549E.pdf
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Figure 2-1 Create a New Project 

 

 

Select Platform and Configuration 

Select "Debug" and "Release" as the platform and configuration, as 

shown in Figure 2-2. 

Figure 2-2 Select Platform and Configuration 

  



2 GOWIN MCU Designer 2.2 Project Template 

 

IPUG928-2.0E 17(33) 

 

Select Toolchain and Path 

Select "arm-none-eabi-gcc" as the cross toolchain and its path, the 

default Toolchain name and Toolchain path are recommended, as shown in 

Figure 2-3. 

Figure 2-3 Select Toolchain and Path 

 

 

Create a Project 

After completing the project creation, navigate to the Project Explorer 

view, select the newly created project, add project structure and code, and 

import the software programming design. 

In the Project Explorer view, select the current project, right-click and 

choose "Refresh" option to automatically update the structure and code of 

the current project. 

2.2.2 Configuration Option 

In the Project Explorer view, select the current project, right click and 

select "Properties > C/C++ Build > Settings" to configure the project 

parameters. 

Target Processor Configuration  

Configure "Target Processor > ARM family", and set this option as 

"cortex-m3", as shown in Figure 2-4. 



2 GOWIN MCU Designer 2.2 Project Template 

 

IPUG928-2.0E 18(33) 

 

Figure 2-4 Target Processor Configuration Option 

 

 

GNU ARM Cross Assembler > Preprocessor Configuration  

Configure "GNU ARM Cross Assembler > Preprocessor > Defined 

symbols (-D)" as "__STARTUP_CLEAR_BSS" as shown in Figure 2-5. 
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Figure 2-5 Cross ARM GNU Assembler > Preprocessor Configuration Option 

 

 

GNU ARM Cross C Compiler > Includes Configuration 

Select "GNU ARM Cross C Compiler > Includes > Include paths (-I)" to 

configure the C header file path, as shown in Figure 2-6. 
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Figure 2-6 Cross ARM C Compiler > Includes Configuration Option 

 

 

Take GMD_RefDesign\cm3_demo software programming reference 

design for an instance, the C header file paths are listed as follows. 

 "${workspace_loc:/${ProjName}/src/library/libraries/cmsis/cm3/device_
support}" 

 "${workspace_loc:/${ProjName}/src/library/libraries/cmsis/cm3/core_su
pport/gmd}" 

 "${workspace_loc:/${ProjName}/src/library/libraries/drivers/inc}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/delay}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/dmm}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/gpio}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/hyper_ram}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/psram}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/spi_flash}" 

 "${workspace_loc:/${ProjName}/src/library/middlewares/uart}" 

 "${workspace_loc:/${ProjName}/src/project}" 
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GNU ARM Cross C Linker Configuration 

Configure the "GNU ARM Cross C Linker > General > Script files (-T)" 

option, and "gw1ns4c_flash.ld" is used as the GMD Flash linker, as shown 

in Figure 2-7. 

Figure 2-7 Cross ARM C Linker Configuration Options 

 

 

Take GMD_RefDesign\cm3_demo software programming reference 

design for an instance, the Flash linker configuration is as follows. 

"${workspace_loc:/${ProjName}/src/library/libraries/cmsis/cm3/device

_support/startup/gmd/linker/gw1ns4c_flash.ld}" 

GNU ARM Cross Create Flash Image Configuration 

Configure "Cross ARM GNU Create Flash Image > General > Output 

file format (-O)", and set this option as "RAW binary" to generate software 

programming Binary file, as shown in Figure 2-8. 
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Figure 2-8 Cross ARM GNU Create Flash Image Configuration Option 

 

 

Devices Configuration  

Configure "Devices > Device selection" option, and set this option as 

"ARM Cortex M3 > ARMCM3" in, as shown in Figure 2-9. 
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Figure 2-9 Devices Configuration Option 

 

2.2.3 Build 

After completing the project configuration and code writing, build the 

current project; click "Build" ( ) or "Build All" ( ) on the tool bar, or click 

"Project > Build Project" or "Project > Build All" on the menu bar to build to 

generate the software programming Binary file, as shown in Figure 2-10. 
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Figure 2-10 Build 

 

2.2.4 Download 

Download software programming design BIN files using Programmer. 

Click "Run> Programmer" on the GMD menu bar or Programmer " " 

on the tool bar to open Programmer, as shown in Figure 2-11. 
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 Figure 2-11 Programmer Option 

 

 

Click "Edit > Configure Device" on the menu bar or Configure Device "

" on the tool bar to open the "Device configuration". 

If FPGA product GW1NS-4C/GW1NSR-4C is selected, configuration 

options are as shown in Figure 2-12. 

 Select "MCU Mode" in "Access Mode" drop-down list. 

 Select "Firmware Erase, Program" or "Firmware Erase, Program, 
Verify" in "Operation" drop-down list. 
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Figure 2-12 Configuration Options for GW1NS-4C/GW1NSR-4C 

 

 

If FPGA product GW1NSER-4C is selected, configuration options are 

as shown in Figure 2-12. 

 Select "SecureFPGA Mode" in "Access Mode" drop-down list. 

 Select "Firmware Erase, Program Securely" in "Operation" drop-down 
list. 
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Figure 2-13 Configuration Options for GW1NSER-4C 

 

 

 Import software programming BIN file in "FW/MCU/Binary Input 
Options > Firmware/Binary File". 

 Click "Save" to complete the configuration. 

Note! 

Import hardware design bitstream in "Programming Options > File name", please refer to 

IPUG932, Gowin_EMPU(GW1NS-4C) Hardware Design Reference Manual. 

After device configuration, click Program/Configure ( ) on the 

Programmer toolbar to complete the download of software programming 

Binary file and hardware bitstream file. 

2.2.5 On-line Debug 

After downloading software programming Binary file and hardware 

bitstream file, if there are any design issues, you can use J-LINK emulator 

to debug on-line ( The on-line debug design must be same with the one 

downloaded to the chip）. 

The single-step debug flow includes: 

 Software debug level configuration 

 Configure software debug 

 MCU JTAG mode switch 

http://cdn.gowinsemi.com.cn/IPUG932E.pdf
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 MCU JTAG interface switch 

 Connect debug emulator 

 Start software debug 

Software Debug Level Configuration 

In the Project Explorer view, select "Properties> C/C + + Build> 

Settings> Settings> Tool Settings> Debugging> Debug level", and the level 

Default(-g) or Maximum(-g3) is recommended, as shown in Figure 2-14. 

Figure 2-14 Software Debug Level Configuration 

 

 

Software Debug Configuration Option 

Select "Run > Debug Configurations > GDB SEGGER J-Link 

Debugging " and right-click "New" to create the project debug configuration 

options, as shown in Figure 2-15. 
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Figure 2-15 Software Debug Configuration Option 

  

 

Select the created debug options. 

1. Select "Main" to configure the Project and C/C++ Application options of 

the current debugging project, as shown in Figure 2-16. 

Figure 2-16 Main Configuration Option 

 

 

2. Select "Debugger" to configure the J-Link and GDB options of the 
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current debugging project, as shown in Figure 2-17. 

For example: 

 Device Name: Cortex-M3 

 Endianness: Little 

 Connection: USB 

 Interface: JTAG 

 Connect to running target：Close 

 Initial speed：Fixed 1000KHz 

 GDB port：2331 

 SWO port：2332 

 Telnet：2333 

 Verify downloads：Open 

 Initialize registers on start：Open 

 Local host only：Open 

 Other options：-singlerun –strict –timeout 0 –nogui 

 Command：set mem inaccessible-by-default off 

Gowin_EMPU(GW1NS-4C) supports JTAG debug interface. SWD 

debug interface is not supported. 

"Connect to running target" option is disabled. 
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Figure 2-17 Debugger Configuration Option 

 

 

MCU JTAG Mode Switch 

Switch JTAG mode from the download to debug mode using 

Programmer. 

Click "Run> Programmer" on the GMD menu bar or Programmer " " 

on the tool bar to open Programmer as shown in 2-11. 

Click "Edit > Configure Device" on the menu bar or "Configure Device 

" ( ) on the tool bar to open the "Device configuration". 

If FPGA product GW1NS-4C/GW1NSR-4C is selected, MCU JTAG 

mode configuration options are as shown in Figure 2-18. 

 Select "MCU Mode" in "Access Mode" drop-down list. 

 Select "Connect to JTAG of MCU" in "Operation" drop-down list. 
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Figure 2-18 MCU JTAG Mode Configuration for GW1NS-4C/GW1NSR-4C 

 

 

If FPGA product GW1NSER-4C is selected, MCU JTAG mode 

configuration options are as shown in Figure 2-19. 

 Select "SecureFPGA Mode" in "Access Mode" drop-down list. 

 Select "Connect to JTAG of MCU" in "Operation" drop-down list. 

Figure 2-19 MCU JTAG Mode Configuration for GW1NSER-4C 

 

 

 Click "Save" to complete the configuration.  

After device configuration, click "Program/Configure" ( ) in the 

Programmer tool bar to complete MCU JTAG mode switch. 

MCU JTAG Interface Switch 

Taking DK-START-GW1NSR4C-QN48G V1.1 for an instance, switch 

SW3, SW4, SW5, SW6 (TCK, TDO, TDI, and TMS of JTAG interface) on 

the development board from "FT232" (Download to "J-LINK" (debug). 

Note! 

 The development board must be kept on power in MCU JTAG mode and interface 
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switch. 

 If the development board powers off in the process, it will restore to MCU JTAG 

download mode automatically after power on. 

Start Software Debug 

Connect J-LINK emulator. 

You can perform operations of breakpoint setting, single-step debug, 

reset, run, etc. by clicking Debug " ", as shown in Figure 2-20. 

Figure 2-20 Start Software Debug 

 

2.3 Reference Design 

Gowin_EMPU(GW1NS-4C) supports reference design in GMD (tested 

software version V1.2), and you can click here to get the following 

reference design: 

…\ref_design\MCU_RefDesign\GMD_RefDesign\cm3_demo、

cm3_freertos、cm3_rtthread_nano、cm3_ucos_iii 

https://cdn.gowinsemi.com.cn/Gowin_EMPU(GW1NS-4C)_V2.0.zip
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