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1 Software Environment 

Table 1-1 Software Environment 

Windows 
Win7/8/10/11 (64bits) 

Win XP (32bits) 

Linux 
Centos6.8/7.0/7.5 (64 bits) 

Ubuntu18.04/20.04LTS 
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2 Software Download 

Gowin Software installation packages and Gowin License Server for 

floating license are available at Gowin Website: 

https://www.gowinsemi.com/en/support/download_eda/. There are 

Windows and Linux versions for you to choose. 

 Installation package for Windows: Gowin Software for Win (Vx.x.x). 

 Installation package for Linux is compressed with the name "Gowin 

Software for Linux (Vx.x.x)". 

 Floating license server software for Windows: Gowin License Server 

for Win. 

 Floating license server software for Linux is compressed with the name 

"Gowin License Server for Linux". 

Note! 

 You need to register and log in to the Gowin website before downloading the 

installation package. 

 "x" in "Vx.x.x" means the software version.

https://www.gowinsemi.com/en/support/download_eda/
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3 Software Installation 

3.1 Software Installation: Windows 

After downloading, double-click Gowin Software installation package 

and install according to the prompt. The installation directory can be 

changed as required. After installation, the shortcut will be created on the 

PC desktop. 

3.2 Software Installation: Linux 

After downloading and decompressing the release, double-click Gowin 

Software installation package and install according to the prompt. The 

installation directory can be changed as required. After installation, the 

shortcut will be created on the PC desktop. The decompressing command 

is "tar -zxvf *tar.gz". 

3.3 Notes for Software Installation 

3.3.1 Notes for Windows 

 You must close anti-virus programs before installing Gowin Software. 

 The installation path should not contain any chinese characters or 

spaces. 

3.3.2 Notes for Linux 

 Root permission is required to start programmer. 

 After decompressing the file, it is recommended that you use the 

"chmod" command to modify the permissions of the associated 

executable files. 
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3.4 Installation Directory 

When Gowin Software installed in Windows, the installation directory 

of IDE, Programmer, and an executable file ("uninst. exe") for uninstalling 

Gowin Software will be created under the installation directory 

"path\Gowin_Vx.x.x", as shown in Figure 3-1. There is no "uninst. exe" in 

Linux, other directories (IDE and Programmer) are the same as those in 

Windows. This section uses Windows as an example to introduce Gowin 

Software installation directory. 

Figure 3-1 Installation Directory  

 

3.4.1 IDE Directory 

The IDE folder is the installation directory of Gowin Software, as 

shown in Figure 3-2. The bin folder includes executable files such as 

gw_ide.exe and floorplanner.exe. Double-click "bin\gw_ide.exe" to start 

Gowin Software directly. The doc folder contains Gowin software user 

guides. The simlib folder is the simulation library of Gowin Software. 

Figure 3-2 IDE Directory 
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3.4.2 Programmer Directory 

The Programmer file is the installation directory of Gowin programmer, 

as shown in Figure 3-3. The bin folder is a directory of executable files. 

Double-click "bin\programmer.exe" to start Gowin programmer directly. 

Figure 3-3 Programmer Directory 

 

3.4.3 uninst.exe 

Uninst.exe, an executable file, uninstalls Gowin software. Double-click 

uninst.exe and Gowin Vx.x.x Uninstall prompt box pops up, as shown in 

Figure 3-4. Click "Yes" to uninstall Gowin software. 

Figure 3-4 Uninstall Software 
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4 Software License Configuration 

4.1 Overview 

This chapter describes the software license configuration. 

4.1.1 License Definition 

The software license is a format contract between the user and 

GOWIN Semiconductor to define and limit the rights of users and the 

obligations of GOWIN Semiconductor. 

Software license consists of three elements: license type, MAC (Media 

Access Control) address, and term of validity. 

4.1.2 License Type 

Gowin Software licenses support node-locked license and floating 

license. 

A Node-locked license is a license based on MAC address. A user who 

obtains the node-locked license can only use the software on the device 

with the matching MAC address. 

A Floating license requires the MAC address of server being used to 

host the license on the LAN. There is a limit on the number of users, but 

there is no limit on the maximum number of users. Any user on this LAN 

(authorized by the administrator) can use this license. 

4.1.3 License Usage 

Both Windows and Linux operating systems can use the node-locked 

or floating licenses. The use of the license is as follows: 

1. A single user with a stand-alone PC in which the license and Gowin 

Software are installed can use either the node-locked license or the 

floating license. 
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2. Multiple users with multiple stand-alone PCs in the same LAN, Gowin 

Software installed on each PC, can apply for a floating license. The 

floating license is installed on one PC in the LAN, and other users 

obtain the floating license by connecting to the IP of this PC, as shown 

in Figure 4-1. 

Figure 4-1 Floating License Installed in Server 

Floating 
License

Gowin 

Software

Gowin 

Software
Gowin 

Software

 

 

3. Multiple users with multiple stand-alone PCs in Windows operating 

systems in the same LAN can apply for a floating license. Install Gowin 

Software and floating license in the Windows server operating system. 

Users can log in to their accounts on their PCs (for example, log in via 

remote desktop) to access the Windows server, and directly use Gowin 

Software and license on the Windows server, as shown in Figure 4-2. 

4. Multiple users with multiple stand-alone PCs in Windows operating 

systems in the same LAN can apply for a floating license. Install Gowin 

Software and the floating license in the Linux operating system. Users 

can log in to their accounts on their PCs (for example, log in through 

Exceed onDemand Desktop client) to access the Linux server and 

directly use Gowin Software and license on the Linux server, as shown 

in Figure 4-2. 

5. Multiple users with multiple stand-alone PCs in Linux operating 

systems in the same LAN can apply for a floating license. Install Gowin 

software and floating license in the Windows server operating system. 

Users can log in to their accounts on their PCs (for example, log in 

through the RDP protocol) to access the Windows server, and directly 

use Gowin Software and license on the Windows server, as shown in 

Figure 4-2. 

6. Multiple users with multiple stand-alone PCs in Linux operating 

systems in the same LAN can apply for a floating license. Install Gowin 

software and the floating license in Linux operating system. You can 

access the Linux server on their PCs (such as VNC Sever) and directly 

use Gowin Software and license on the Linux server, as shown in 

Figure 4-2. 
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Figure 4-2 Floating License and Gowin Software Installed on Server 

 

4.1.4 MAC Address Acquired  

The way Windows PCs acquire MAC addresses is as follows, taking 

Windows 10 as an example. 

1. Click "Start" menu and open command prompt. 

2. Type "ipconfig/all" in the command prompt and press enter. 

3. The physical address is as shown in the red box in Figure 4-3. 

Figure 4-3 MAC Address in Windows 10 

 

 

The way Linux PCs acquire MAC addresses is as follows, taking 

Centos 6.8 as an example. 
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1. Open terminal 

2. Type "/sbin/ifconfig" at the terminal and press enter. 

3. The physical address is as shown in the red box in Figure 4-4. 

Figure 4-4 MAC Address in Centos6.8 

 

4.1.5 Apply for Gowin Software License 

Apply for Gowin software license at Gowinsemi website: 

https://www.gowinsemi.com/en/support/download_eda/ or contact Gowin 

FAE.  

The page of applying for License is shown in Figure 4-5. 

https://www.gowinsemi.com/en/support/download_eda/
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Figure 4-5 Applying for License Page 

 

 

License type: Node-locked and Floating.  

The service period of the applied license is one year by default, and 

you can apply again after it expires. The floating license supports ten users 

by default, and there is no limit on the number of the maximum users.  

4.2 Gowin License Configuration: Windows 

The configuration mode in Windows system is the same, using 

Windows 10 as an example. 

Gowin Software checks the license automatically when you open it. If 

the license is not correct, the software will not open, and an error message 

will pop up, as shown in Figure 4-6. After clicking "OK", License Manager 

dialog box pops up, as shown in Figure 4-7. 

Figure 4-6 License Error  
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Figure 4-7 License Manager Dialog Box 

 

4.2.1 Node-locked License 

For the first time to configure license, select "Use Local License File" 

and click "Browse…" to add the file path for node-locked license, as shown 

in Figure 4-7. Click the "Check" to test the connection, and the INFO dialog 

box will pop up when the connection is successful, as shown in Figure 4-8. 

Click "Save" to save the current configuration. 

Click "Help > Manage License…" in the menu bar to open the "License 

Manager" to update configuration, as shown in Figure 4-7. 

Figure 4-8 INFO Dialog Box 

 

4.2.2 Floating License 

Floating license needs to be authorized using Gowin License Server 

developed by GOWINSEMI. There are three ways to start the license 

server. 

 Command line 

 Auto-startup on boot 
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 Windows service 

Command Line 

There are two ways to start. 

1. Double-click "license_server.exe". Copy the floating license file (such 

as "gowin_license.lic") to the path where "gwlic_server.exe" is located. 

Rename the floating license file as "gowin.lic". Double-click 

"license_server.exe ". 

2. In the cmd window, execute the "path\license_server.exe -s 

path\gowin_license.lic -b ", as shown in Figure 4-9 . 

Note! 

 -s: Load license file. 

 -b: Run the license service in the background. 

 -p: Specify the port, 10559 by default. 

 Figure 4-9 Gowin Floating License Server Startup Window 

 

 

 After starting successfully, type the server IP address in the "License 

Manager" view, as shown in Figure 4-10. 
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Figure 4-10 License Manager Dialog Box 

 

 

 Click "Check" to test the connection. If it is successful, INFO dialog 

box will pop up, as shown in Figure 4-11. 

Figure 4-11 INFO Dialog Box 

 

 

No matter what type of license is configured or updated, the software 

will automatically write the license configuration information to the 

configuration file "\IDE\bin\gwlicense.ini" in the installation directory, as 

shown in Figure 4-12 . 

Figure 4-12 License Configuration File 
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Note! 

If the gwlicense.ini file cannot be saved due to the lack of permissions of the configuration 

file in Gowin Software installation directory, click "Save" button, and a prompt will pop up. 

At this point, you need to add write or modification permissions to the gwlicense.ini file. 

Right-click the file and select the "Property > Security", as shown in Figure 4-13. After the 

permissions changed, the license will be configured again. 

Figure 4-13 Permission Changed 

 

 

Auto-startup on Boot 

Use Windows 10 system as an example to introduce the auto-startup, 

and the startup needs to run with Administrator account. 

1. Preparation for the batch file 

Create a batch file with extension.bat, such as, 

"startFloatingLicense.bat". You can write the command into the file, 

such as "start path\license_server.exe -s path\gowin.lic -b". 

2. Copy the batch file to the startup folder. 

 Open Run dialog box (win +R) and type "shell:startup", as shown in 

Figure 4-14. Press Enter to pop up the folder as shown in Figure 4-15 

and copy the "startFloatingLicense.bat" to this folder. 
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Figure 4-14 Run shell:startup 

 

 

Figure 4-15 Startup Folder 

 

 

3. Check the setting.  

Open task manager to check the setting. If the 

"startFloatingLicense.bat" is enabled, the setting is successful, as 

shown in Figure 4-16. 

Figure 4-16 Task Manager 

 
 

Windows Service 

Use Windows10 system as an example to introduce Windows service 

startup. The service runs with administrator permission and make sure that 
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the LAN communication is normal before startup. 

There are two ways to add Windows service. 

1. Go to the service startup package directory 

gowinLicenseServer\gowinLicenseServerForWindows\bin, right-click 

and select administrator to run the batch file 

"gowinLicensingServiceAdding.bat". 

2. Or you can open the command window as an administrator and 

execute the batch file "gowinLicensingServiceAdding.bat". 

A prompt "Windows service has added successfully!" pops up if 

succeed, as shown in Figure 4-17; and the service is in the Stopped status, 

as shown in Figure 4-18. 

Note! 

If the LAN communication is not normal, you can try to shut down the system firewall and 

use the ping command to test whether the LAN communication is normal. 

Figure 4-17 Startup Window 

 

 

Figure 4-18 Task Manager 

 

 

There are three ways to run the service and here it uses the service 

name "gowinLicenseService" as an example. 

 The command line: After executing sc start gowinLicenseService, you 

can check the status through the task manager, as shown in Figure 

4-19. 
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 GUI: You can start the task manager and right-click 

gowinLicenseService to select "Start". It displays "Running" if succeed. 

 Restart the system to automatically run the service. 

Figure 4-19 Task Manager 

 

 

You can test the service. Open the license manager window and fill in 

the host IP address in "License Server" and the port in "Port"; click "Check", 

an INFO prompt will pop up, displaying "Service is OK", "Address", and 

"EXP. date", as shown in Figure 4-20. 

Figure 4-20 License Configuration 

 

 

You can run following commands to stop and delete service. 

 Service stop command: sc stop gowinLicenseService  

 Service delete command: sc delete gowinLicenseService  



4 Software License Configuration 4.3 Gowin License Configuration: Linux 

 

SUG501-1.4E 18(24) 

 

4.3 Gowin License Configuration: Linux 

License configuration in Linux is the same, using Centos6.8 as an 

example to illustrate. 

Gowin Software checks the license automatically when you open it. If 

the license is not correct, the software will not open, and an error message 

will pop up, as shown in Figure 4-21. After clicking "OK", License Manager 

dialog box pops up, as shown in Figure 4-22. 

Figure 4-21 License Error  

 

 

Figure 4-22 License Manager Dialog Box 

 

4.3.1 Node-locked License 

For the first time to configure, select "Use Local License File" and click 

"Browse…" to add the file path for node-locked license, as shown in Figure 

4-22. Click "Check" to test the connection, and the INFO dialog box will pop 

up when the connection is successful, as shown in Figure 4-23. Click 

"Save" to save the current configuration. 

Click "Help > Manage License…" in the menu bar to open the "License 

Manager" to update configuration, as shown in Figure 4-22. 
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Figure 4-23 INFO Dialog Box 

 

4.3.2 Floating License 

Floating license needs to be authorized using Gowin License Server. 

There are two ways to start the license server. 

1. Double-click " license_server" to start. Copy the floating license file 

(such as gowin_license.lic) to "license_server". Rename the floating 

license file as "gowin.lic"; double click-on "license_server". 

2. Commands Mode. In the Terminal window, execute 

path/license_server -s path/gowin.lic, as shown in Figure 4-24.  

Figure 4-24 Gowin License Server Startup Window 

 

Note! 

 -s: Load the license file. 

 -p: Specify the port, 10559 by default. 

 If you copy the floating license file (such as gowin_license.lic) to the path of 

"license_server" and rename it to "gowin.lic", you can start Gowin License Server 

using the command line just typing path/license_server, as shown in Figure 4-25. 

Figure 4-25 Gowin License Server Startup Window 

 

 

After successfully starting the server, type the license server IP 
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address in the "License Manager" dialog box, as shown in Figure 4-26. 

Figure 4-26 Floating License Configuration  

 

 

Click "Check" to test the connection. If it is successful, INFO dialog box 

will pop up, as shown in Figure 4-27. 

Figure 4-27 Test Connection 

 

 

No matter what type of license is configured or updated, the software 

will automatically write the license configuration information to the 

configuration file "\IDE\bin\gwlicense.ini" in the installation directory, as 

shown in Figure 4-28 . 
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Figure 4-28 License Configuration File 

 

Note! 

If the gwlicense.ini file cannot be saved due to the permissions of the configuration file in 

Gowin software installation directory, click "Save", and a prompt will pop up; you need to 

add the write permission to the gwlicense.ini file; execute the command "chmod +x <file>" 

in the terminal to modify the file permission. 

4.4 License Expiration Reminder 

Every time you open Gowin Software within 16 days of the license 

expiration, Gowin Software will remind you of the license expiration, as 

shown in Figure 4-29. Click "OK", the software can be used normally. 

Figure 4-29 License Expiration Reminder 
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5 Software Startup 

5.1 Software Startup in Windows 

Use Windows 10 system as an example. 

5.1.1 GUI Mode 

 Double-click the shortcut " " to start Gowin Software. 

 Double-click the "gw_id.exe" file in the "installation directory 

\Gowin_Vx.x.x\IDE\bin". 

 Open cmd window and type "installation 

directory\Gowin_Vx.x.x\IDE\bin\gw_ide.exe". 

 Double-click the project file ".gprj". 

5.1.2 Command Line Mode 

In the cmd prompt, enter "path\IDE\bin\gw_sh.exe". See appendix A of 

SUG100, Gowin Software User Guide. 

5.2 Start Software in Linux 

Use Centos6.8 system for an example. 

5.2.1 GUI Mode 

 Double click the "gw_ide" file in "installation directory 

Gowin_Vx.x.x\IDE\bin ". 

 Run the command in the terminal: path/Gowin_Vx.x.x/IDE/bin/gw_ide. 

http://cdn.gowinsemi.com.cn/SUG100E.pdf
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5.2.2 Command Line Mode 

In the terminal, type "path\IDE\bin\gw_sh". See appendix A of SUG100, 

Gowin Software User Guide. 

http://cdn.gowinsemi.com.cn/SUG100E.pdf
http://cdn.gowinsemi.com.cn/SUG100E.pdf
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6 Exit Software 

6.1 Exit Software in Windows 

There are two ways to exit the software: 

 Select "File > Exit"; 

 Click the " " icon on the upper right of the software. 

6.2 Exit Software in Linux 

There are two ways to exit the software: 

 Select "File > Exit"; 

 Click the " " icon on the upper right of the software. 
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