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1.1 FHAR

A F MR & =2 SRR 2 T B Gowin Programmer f1 77k

A RATFE P IR B AT S T A B AT SCRF I 7 i B R AEE S, 2 0 1.7.1Beta
FRAS o DURAPERRAS )T, (5 B Al RE i 2 5%, BARCUH P AR
B

1.2 B~

AR r R 5SS IE A PR 7

e GWIN(R)A%I FPGA F=fii: GWIN-1, GWIN-2, GW1N(R)-4;
o GW2A(R)#7%I FPGA /= ii: GW2A(R)-18; GW2A-55;

1.3 HX3HH

I B S w2k Sk M Eh hitp://www.gowinsemi.com.cn T DL R #. 7
LA AH I SRy

e SUG100-1.08_Gowin = JE#FFH F 6 7
® TN653-1.03_Gowin FPGA 7=} JTAG Fic & Tt
e UG290-1.01 Gowin FPGA 7= /it 4 FHc & T/t
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1 RFARFM

1.4 RiE. 4ingiE

1.4 RiG. 4aR&iE

AT W HARARE . FinETE SRR E 2 IR 1-1.
& 1-1 RiE. FEWIF

ARG GG 1E | A X

FPGA Field Programmable Gate Array BT AR T %)
SRAM Static Random Access Memory FRSKENLA i
110 Input/Output i NI

BSDL Boundary Scan Description Language HRARRES

1.5 FRZ SRR

ez PRSI AT REEOR SR, A A IR rP QA A A 5 ) B A
M EZES A AR

Mk:  http://www.gowinsemi.com.cn/

E-mail: support@gowinsemi.com
Tel: +86 755 8262 0391
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Gowin Programmer & Zda i 34 T 88 FPGA & #& 1 AF, EfEH
A AT, SR TR IS (BRIAC 5 523, ZIREN A T2k i
2N driver SCHRJETR, (R ATIE# € D& o Tk FPGA TNHZk.

Gowin Programmer FH 7 N HEAZO©, TEMO, WAFRK O MG
MR @, 4k 2-1 fios.

[ 2-1 Gowin Programmer 7

Wmmmil----------:-

@ H as >
Enable Famdly Device Cperation Checksum User Code IDCODE
@ i GWIN GWIN-4 Fead [0 Code CLOQIELE
FaC Gwia GWIa-5S exflash Program Eylsersfroot/Deskiop besifs OwCCH Ow00000000  OuwOO00ZEIB
Darpan -]
@7’
Guigwt | Errer | Tarming | Infs
( ) Sy e ( :) Sy S
7N — ~NI1=
S AN
@ B @ SR

WEFRE

WERRIE DR TR BT RIER e P TA W&, XER&ETLLEH
FFREIRS, W bUEd FE R E RS .. BN ATARR 0%, B%
FERE T KR F R TR AT 0 T SE PR View SRk B B oR BRI . A F A% 41k T
n#k 2-1 s
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+® 2-1 {EFK

A 3% T3 iR

Enable Al gniE, i RARER R TR & TR
!
M £ N Enable SR G R, R s 20 W S A ERE
WRIEATHE R i THRESIHRE, Ra2et #wiE
TFEEEFERAEAT, WO EYEE AR AR

Vendor LINGY

Family Al Ymte, R R A AT Y

Device Al Y, PR bR A B AT g

Package BOABSTE, PIgnfE, Sy bR e BT R

Operation ANTT Y, X AT IS A L E X UEAE (Device
Configuration Dialog) #AT#fEEERECE, TEA(E
B 5% 3.6 it B B i,

File R,y bR A IR AT SR

Checksum AT kR, B AT P& B E X1 HE (Device
Configuration Dialog) #AT4mfE#R/EMACE, TEAHE
BiE5% 3.6 it B & A mFE Rl

User Code AT gmt, XA RC E X TEHE (Device
Configuration Dialog) #4742/ EINCE, 1EAI(E
HiE 2% 3.6 i B W& g e

IR Length ENINISE: B

IDCODE AT Y, AT RSB EXTIEHE (Device
Configuration Dialog) #AT4mfE#R/EMACE, TEAHE
S5 3.6 It B W& g e

M R

4 IR EL7 Output, Error, Warning & Info, 2SR5 R, 4
i%’f%‘l%\’ %% %A%\&TE%{%A%\O
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3 L F AR 1.5 Bk S i 5 R it
= s 1o
32&& NER{E
e T HOR R T ARG BRI L 4 B FPGA 1245 SRAM. KA
3 Flash 8040 Flash it 2, gwfe N8 ERENE 3-1 s
31 wETEHRERE
( VARG )
\ e A T
T T T T B FRAKN, 501
I TRRITT BRI T (47 SR B0 S AT IR A5
TH TR AR .
Y A B o R SRR EL NI £ 55
R T TERSERREREIRE, VR 4
R TR B 7 75 O B SO
@
v R E R R TR TR, R
| EWETR CEPSE T
) 4
gl
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3 GFE T A ERAE 3.1 W B Pk

31 WETHLk
WHE TR RIE AR N HOEEE T M T 8288 u D AR EE B
Gowin Programmer BRI #5858 — AT I N 3mSR ER AL
15MHz.,
FESEEARE PR Rk FE “Edit>Setting>Cable”, 3TJT Cable Setting i
HE, Wil 3-2 Fios.

3-2 Cable Setting

W Cable Setting L2 eS|

Cable Setting

[ Auto Detect J

Cable: | GH-USB (FTDL) v
Port: | FTUSE-0 v |
Frequency: [ISM}{z V}

| ok || Cancel

K 3-2 S HURE AN 3-1 Fs .
% 3-1 Cable Setting ¥

A 346 15 it
H M ETA 51 ENER D) N, Bk RE
Auto Detect TR R R
Cable TR, BRI GW-USB(FTDI).
Port ARG AT ARG, BRI EE S — AN ] g ]

T 4%, Tk 30MHz, 15MHz,2.5MHz,2MHz,
1.5MHz, 0.75MHz, 0.1MHz, ERil\N 2MHz.

Frequency

3.2 QIEFTIE
E!
BEH TRE 4 M 24 1 TR .
BB TR RN G F TR A7 gm AL B 1 e, @it DA = Fho5 R )
TR
e f[JF Programmer 2 H 31— B THE;
o {ESEHARIPRIGIATE “File>New”, OJE /N TIE:

o i THRMES “ = 7, BN LR

SUG502-1.1 6(15)
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33NHEAF LR

33¥THEREIERE

!

PO TRES R H 2T AL

ITTF DRSO 75 25 B B R 3, IFORIE N B2 i a6 A AL HEBC B 55 TR SC P i
R —3. RTIRE FHREMREEESS 3.1 WE ML, KT &R EAMR
FEES% 3.5 MBS R

07 A LRERIHT T O 0 AR SO U AR R B, I PR Ry 5

AT EH LE:
o {ERHEFIPIKIIESE “File>Open”, $TH—ACF TH;

o i THA&ES “

34 PR ERLE

7, AT A A TR

Programmer 3ZF H i 5 iF EVUER I BEE8E . ATIEE LU

o7 24 v o g e B

o TEHFHIKIKIERE “Design>Scan”, %5 THEAAHE 1% 1L 5

o b THREE L F SN RIS TERE
R TERE, BT s &R 12 H AR 5 PR 4K R 1 T Gowin

Programmer i # £ &4, Wl 3-3 s

A
B 3-3 & &RE
DEE as ]
Enable Family Device
1 GWI1N GWI1N-4 SRAM Program with Security
2 GW2A GW2A-55 SRAM Program with Security
E!

ik A MER ID (1 GW2A-18/GW2AR-18),

B

SUG502-1.1
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T 5E B 5 T B8 E X R
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3 g T HdRAt 3.5 MAc & B & A 1L B

35 BLEREREHE

Programmer SCHF FaIECE & A e e, WM, Bhiks, &
SO A AEBE P L B SR AT

3.5.1 RN &

SN DRI B

1. 7ESEERI PR IGESR “Edit-Add Device” Bk Ead T HAZERR “ 97, &
In—A Bt &

2. iy “Family”, 8Tz 5E ke 5%

3. il “Device”, ML T ik AR AR 5.

YE!
Y REGEPE, RS RINEERTAE, BN SIS INESR IR R .
3.5.2 BiS &

2% DL N P R R B4
1. e B edT

2. TEEARL K I Edit> Remove Device ” 8 i T B AL KR« @7
AT S
3.5.3 g R ERPMNE
2 DN 45 TS BV 4% 70 e P T B
1. & FEAT;

2. fESEH AR Edit>Up/Down” st ot T Bk e | s L »
0 12 7 et i
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3 GFE T A ERAE 3.6 ML & & A Y FE e lE

3.6 BLE R ZHRIZRRIE

IR AT, @I LU =75 2UAT4TJF “Device Configuration” %
T AE s
1. 7R IRIER: “Edit>Configure Device ”;

2. B TAREE < 7 7
3. Xl Operation 41| ¥.70H% 4T FF “ Device Configuration” XHiGHE, U1k 3-4
Fr7s o

3-4 Device Configuration

i B’

Wy Device Configuration ? 2

Dewice Operation

Access Maode: [External Flash Made T]

Operation: [exFlash Progzram "]

Frogramming Options
Frogramming File: C:/test. fs :]

Extend Flash Options

Devi ce! MXIC MKZ5L12E35F -
Start Addrss: | 0x00000000 x|
| 0K || Cencal

K 3-4 S ER IR 3-2 fs.
%= 3-2 Device Configuration £

S AT iR

Access Mode BV e I OE Y oy L e

Operation TR AR ERAE, TRAE RES WL 3-3.

Instruction Register | 4% %%y ITAG-NOOP I, ik %152 %7 4%

Length KA,

Programming File | i $4m A Ed S

Device M FERE % A External Flash Mode B, &3¢ 41
& Flash %! 5,

Start Address U FER ik B A External Flash Mode I}, %% SPI
Flash #2afaibht, fH/hihk#A7 4 1 Sector (4096
Byetes).

SUG502-1.1 9(15)




3 iR FEIRIE 3.6 Mo & W & MR IR
* 33 IR EHERE
Access Mode | Operation Description
SRAM Mode Bypass AKS 1 A REAT AR A #4
Read ID Code B ID.
Read Status Register | 152 H % &R A5 .
Reprogram i H Ak
SRAM Program B HE S N\ SRAM.
SRAI\Q program and | ¥HHE S5 N\ SRAM FH 4T 50 HE
Verify
Embedded embFlash SR Nk Flash, R EEEHES
Flash Mode' | Erase,Program A
embFlash JHEBR W R Flash, SR EHdES
Erase,Program,Verify | X 3:3t475630F .
embFlash Erase AN % Flash.
Only
External Flash | exFlash Erase, JHERRANE Flash, SRJEKEHES
Mode Program® Ao
exFlash Erase, J PR AN E Flash, SR EEdES
Program and Verify | A\ Jf 47 560F .
exFlash Erase Only | {Y# &4 E Flash.
exFlash Erase, it boundary scan £, Je 4%
Program 4ME Flash, AEREHEE A
in bscan
exFlash Erase, it boundary scan £, Je 4%
Program and Verify | 4+& Flash, 2R /E¥%50dE 5 A\ It
in bscan ITESAE
exFlash Erase Only | i#iT boundary scan £, {45 %
in bscan 4NE Flash.
!
[L]IGW2A/GW2AR %741 FPGA /= i A3 Embedded Flash Mode.
[21SRAM Verify ${EE R A il FS SCEERHEASRESE FH 22 447
[3]4E boundary scan £zUF, #fiff config-mode[2:0]=011
SUG502-1.1 10(15)




3 ZfE T HRATE 3.6 BLE W& g FE iR i

3.6.1 it & SRAM #&5%

Z# DN RALE SRAM 5

1. R PTEAT

2. FTHF “Device Configuration” X}iGHE;
Alj@E PLR =R 3T “Device Configuration” X & #E:
a). TERHFFRIRIER: “Edit>Configure Device”;

b). il AR < 7

c). X Operation 7| ¥ ei% 4T “Device Configuration” XJi&HE, U
3-4 iz,

7t “Access Mode” THi%l|EH ik “SRAM Mode”;

4. MRPETHELE “Operation” N HiF1 R H L BEAR N IR
®H!
RS N ER kS (JEmmks (JTAG-NOP) A Ff Bypass #1F), &
EFYIE e TR 2 A7 MK E B 2 X 4511 BSDL (4 Hi Programmer 32 UHE 4 27
K

5. Bl “OK” 52t E .

3.6.2 BEE#X AR Flash ##58 - GWIN(R) &%l FPGA /=&

GWIN(R) 541 FPGA /it A R A3\ Flash, #afetbizUn] LAk 9 ik A
i\ Flash # 2.,
1. &R TEAT;
2. 77T “Device Configuration” Xf1EHE;

i@ PL R =R 5 A FTHF “Device Configuration” X & #E:

a). {EZHFPRIRIEF: “Edit>Configure Device”;

b). it TR < 7

c). X ifi Operation 41| #.0% 4T+ “Device Configuration” XiEHE, 41
3-4 ffirmo.

7t “Access Mode” THi%|FEH 1k “Embedded Flash Mode ”;

TRIE T5 EAE “Operation” 47413 H IR B B (1) 1

5. i “Programming File” % Rif &R “Lo )7 b3t N g fE Bt i
A

6. i “OK” 52/ HE -

3.6.3 Bt E5MEB Flash &3\

5z Programmer 3CH78 FH AR Flash 3474988, 44 Flash #5002
R
1.

2.

w

B w

R A FITAEAT 5

FT7T “Device Configuration” S iHHE ;

Al PR =R 7 s FTH “Device Configuration” X 4G AE
a). TERHFKIRIEF: “Edit>Configure Device”;

SUG502-1.1 11(15)




3 g T HdRAt 3.6 BLE W& g FE iR i

b). Hoh TEALEHR < 7 7

c). X il Operation 41| ¥.6i% 4T FF “Device Configuration” XiGHE, 41
Kl 3-4 7R

7t “Access Mode” 1% HiEFE “External Flash Mode”;

4. FRYETEEAE Operation” T H7 513K IR A N I #4E, WS “Operation”
#F “exFlash Program”, FE{E “Programming File” Hk 5% M 1)
G FEBHE I SCAF 5

5. f£ “Device” THiy|FR AR HISME Flash 215,

7£“ Start Adress” N hi 51| R ik #2408 Flash BAZ a6 H4E, BRI A 0x00;

7. B “OK” 5EHLE .

w

o

SUG502-1.1 12(15)




3 g T HdRAt

3.7 g I IR

3.7 43S RS

SUG502-1.1

Programmer {1 ] 1/0O State Editor - B 4w 4 A4 5| IFIE, nrLhik
B S| ERME PR ARG . 25 LT SR 5| IR
1. & AEAT
2. FESEHRLPRIRIERR “Edit>Edit /O State” BUAEXT N e 4F—47 s bR
FEE, %P “Edit /O State”, $7HF “1/O State Editor”, K 3-5 Ain;
3. EFMA W AT AE LT BSDL U
4. @I R B AR AT B S B 5| BRI PR A B B A BT 5 A BT
FERPIRES o

[ 3-5 I/O State Editor

$& 1/0 State Editor P| =
I0 State: Custom ']
BSDL File: C:/Users/rootf/Desktopfio_state/zwin_4_lqfpl4d hzm :]
3 7 2 g 10
Fin 1 to 10 = o o L o . L L
Pin 11 to 20 0 L [EEJfeEgo - =
Pin 21 to 30 4] L 4] L 0 0 L
Pin 31 to 40 [EEL EML -o L D
Pin 41 to 50 L 0 L o0 L o L o0 L |0
pinsi1toeo L o [ElL EBoc © o © o
Pin 61 te 70 L © L 0 L |0 L o0 L O
pin 71 to 80 L L ENEN°  EN° o ¢
Pin 81 to 90 © L o L o L o L [Elo
Pin 91 to 100 |G © L o L 0 0 L
Pin 101 teo 110 0L i : Bl -- = |
Pin 111 to 120 L © L 0 L |0 o
Pin 121 to 130 L 0 L L [Elo L 0 L
Pin 131 to 1400 L © L (0 L 0 L 0 L
Pin 141 to 150 0 L 0 |0
State Description
X BSDL Default
u Output High Submit ][ Capture ][ Cancle
L Qutput Low
1 Input  High
0 Input  Low

13(15)
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3.8 I

3.8 BRI

1A 085 B LERFAR SO R IS, 75 2R LUARHR S B B S N FPGA.
W& FTTEAT, It e BRI IE SR “ Edit>Configure Security” 547 #iidk
& “Configure Security”, #TJF “Security Configuration” XfiEHE, 1% 3-6
P o

R 128bits, HIUHIRASA 0x0, KA MR AES Rtk — bk
R as . BVRE—Ar 5 1 )5 67508 0.

HPUE S, TCIE TR PR T g AR AT L
[#] 3-6 Security Configuration

P

Wy Security Configuration ¥ 2

Key (Hext):

A1BFFEETC

write I I read J I lock

Lock : Befuse to write and read -

Read ! Bead and display the kew(if unlocled)

Write : Frogram the ey to FPGA -

Kl 3-6 SRR IR 3-4 PR

%% 3-4 Security Configuration £
SR A
Write 48 € 1 Key (5 AN FPGA 1,
Read FEARBUERITHOLR, B IFER FPGA WY key {H.
Lock B FPGA NI key, BU€ 5 LiERETIE.
E!

%A key CLAHME, Programmer 2x#g7x C&HE, A2 &7~ Security Configuration
XA o

3.9 RELHAEE

SUG502-1.1

FEORAFSCAF AR T 8T, /5 2 A 2 A B2 5 A B

fESE A iR “Design>Check” st T AR Bt (07 gy
GEFEE
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3 g T HdRAt 3.10 fRA7 AT B 2 TR

310 REYAEER TEXH

TR B AL BT R T LR Ry RS DA I
fESE RS “File>Save” s LR « B (g

3.11 wiz T

BN R G e HEA I B S UR , S FAE L FE “Design>Run” B
di LEAER “F 7 SR dt T wmfs T3, &S5 R B RrEf R .

3.12 File Convertor M #t## T A

— ARSI A TR, FEMTREGESER (fs) Uk
o i 1| Y

JR UG B S — A ASCH RS SCA S, &y T hdlise, it scfh 2
SIURE IR S I R SO A
& 3-7 File Convertor

W File Convertor : = | E] S
Conwert to: [BIH ']
Save file as: :]

File Size(bytes) Device Checksum SPI Add
1 D:/DESKTOPfgowin_prjfcompress_dk_1/co... 221350 GWIN-4 07309 Ox111111
“ 1 ¥

SUG502-1.1 15(15)
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