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 更新优化界面配置。 

2019/11/12 1.2 
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 IDE 内部集成 Java Development Kit，简化 IDE 安装流程； 

 IDE 内部集成高云下载软件 Programmer； 

 IDE 界面完全高云定制化，简化界面选项配置，提高 IDE 易用性； 

 解决已知的 IDE 安装和使用问题。 

2019/12/10 1.3 
 License 管理； 

 IDE 界面优化。 

2020/06/01 1.4 

 支持 Gowin_EMPU(GW1NS-4C)和 Gowin_EMPU_M3 编程设

计、编译、下载和在线调试； 

 支持 Gowin_PicoRV32 软件在线调试； 

 集成调试软件 OpenOCD； 

 集成 Olimex 调试仿真器驱动软件； 

 更新下载工具 Programmer，支持 Gowin_EMPU(GW1NS-4C)

下载； 

 更新 Gowin_EMPU(GW1NS-2C)、Gowin_EMPU_M1、

Gowin_EMPU(GW1NS-4C)、Gowin_EMPU_M3、

Gowin_PicoRV32 软件编程参考设计示例； 

 支持 Help 帮助系统，在线查看 GMD 和 Gowin MCU 用户手册。 
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1 关于本手册 

1.1 手册内容 

本手册主要描述高云半导体 GOWIN MCU Designer 的安装及操作，旨

在帮助用户快速熟悉 GOWIN MCU Designer 的使用流程，提高设计效率。

本手册中的软件界面截图和支持的产品列表等信息均参考 GOWIN MCU 

Designer，因软件版本升级，部分信息可能会略有差异，具体以用户软件版

本的信息为准。 

1.2 相关文档 

通过登录高云半导体网站 www.gowinsemi.com.cn 可下载、查看以下相

关文档： 

 IPUG536, Gowin_EMPU_M1 IDE 软件参考手册 

 IPUG519, Gowin_EMPU(GW1NS-2C) IDE 软件参考手册 

 IPUG928, Gowin_EMPU(GW1NS-4C) IDE 软件参考手册 

 IPUG919, Gowin_EMPU_M3 IDE 软件参考手册 

 IPUG910, Gowin_PicoRV32 IDE 软件参考手册 

1.3 术语、缩略语 

本手册中的相关术语、缩略语及相关释义如表 1-1 所示。 

表 1-1 术语、缩略语 

术语、缩略语 全称 含义 

MCU Microcontroller Unit 微控制器单元 

FPGA Field-Programmable Gate Array 现场可编程门阵列 

SoC System on Chip 片上系统 

RISC Reduced Instruction-Set Computer 精简指令集计算机 

ARM Advanced RISC Machine 高级精简指令集计算机 

RISC-V RISC Five 第五代精简指令集计算机 

GNU GNU is Not Unix 自由软件基金会 

GCC GNU Compiler Collection GNU编译器套件 

http://www.gowinsemi.com.cn/
http://cdn.gowinsemi.com.cn/IPUG536.pdf
http://cdn.gowinsemi.com.cn/IPUG519.pdf
http://cdn.gowinsemi.com.cn/IPUG928.pdf
http://cdn.gowinsemi.com.cn/IPUG919.pdf
http://cdn.gowinsemi.com.cn/IPUG910.pdf
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术语、缩略语 全称 含义 

GDB GNU Debug GNU调试器 

OpenOCD Open On-Chip Debugger 开源片上调试器 

IDE Integrated Development Environment 集成开发环境 

PC Personal Computer 个人计算机 

1.4 技术支持与反馈 

高云半导体提供全方位技术支持，在使用过程中如有任何疑问或建议，

可直接与公司联系： 

网址：www.gowinsemi.com.cn 

E-mail：support@gowinsemi.com 

Tel：+86 755 8262 0391 

http://www.gowinsemi.com.cn/
mailto:support@gowinsemi.com
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2 GOWIN MCU Designer 概述 

2.1 简介 

GOWIN MCU Designer 是高云半导体根据自有 FPGA+MCU SoC 架构

的产品特性，基于开源 GNU GCC 编译工具链和开源 Eclipse 框架，自主研

发的新一代 MCU 软件开发环境，支持通用的 C/C++嵌入式软件编程语言，

帮助用户迅速实现 MCU 软件开发过程中的代码编译、链接、产生映像文件

和下载等工作，此外，GOWIN MCU Designer 集成了在线调试工具，便于

用户快速定位分析软件编程问题。 

GOWIN MCU Designer 支持 ARM 架构和 RISC-V 架构 MCU 的编译工

具链，支持 ARM Cortex-M1、ARM Cortex-M3 和 RISC-V 架构的 MCU 编

译、链接、下载和调试。 

GOWIN MCU Designer 提供工程的图形化设置界面，可快速地编辑代

码、查看编译结果，并能快速启动高云半导体 MCU 下载工具将映像文件下

载到芯片，实现用户设计所需的功能。GOWIN MCU Designer 软件界面，

如图 2-1 所示。 
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图 2-1 GOWIN MCU Designer 软件界面图 

 

2.2 处理器支持 

GOWIN MCU Designer 支持的处理器类型、所属架构和芯片，如表 2-1

所示。 

表 2-1 GOWIN MCU Designer 支持的处理器 

处理器类型 所属架构 芯片 

Gowin_EMPU (GW1NS-2C) ARM Cortex-M3 
GW1NS-2C 
GW1NSR-2C 
GW1NSE-2C 

Gowin_EMPU (GW1NS-4C) ARM Cortex-M3 
GW1NS-4C 
GW1NSR-4C 
GW1NRSER-4C 

Gowin_EMPU_M1 ARM Cortex-M1 

GW1N-9 
GW1NR-9 
GW1N-9C 
GW1NR-9C 
GW2A-18 
GW2AR-18 
GW2A-18C 
GW2AR-18C 
GW2ANR-18C 
GW2A-55 
GW2A-55C 

Gowin_EMPU_M3 ARM Cortex-M3 
GW2A-55 
GW2A-55C 

Gowin_PicoRV32 RISC-V 

GW1N-9 
GW1NR-9 
GW1N-9C 
GW1NR-9C 
GW2A-18 
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处理器类型 所属架构 芯片 

GW2AR-18 
GW2A-18C 
GW2AR-18C 
GW2ANR-18C 
GW2A-55 
GW2A-55C 

注！ 

软件版本不同，支持的处理器类型可能会略有差异，具体信息请参考所使用的软件版本。 
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3 GOWIN MCU Designer 安装 

3.1 运行环境 

Windows：Win7/8/10(64bit) 

3.2 软件下载 

GOWIN MCU Designer 安装包 GMD_V1.1.exe 可通过登录高云半导体

官网进行下载：www.gowinsemi.com.cn/prodshow.aspx 

注！ 

软件下载前，需先注册官网并登录。 

3.3 软件安装 
注！ 

 安装 GOWIN MCU Designer 软件前，建议关闭 360 或金山毒霸等杀毒软件； 

 软件安装路径尚不支持含有中文或空格的文件路径； 

 如需安装新版本 GOWIN MCU Designer 软件，建议卸载上个版本之后，再次安装。 

 安装支持选择安装部分，可选择的安装部分如表 3-1 所示。 

表 3-1 Components to Install 

Components 描述 备注 

GOWIN MCU Designer GUI 
GOWIN MCU Designer 软件

图形用户界面 
执行文件 GMD_V1.1.exe 

SEGGER J-Link Driver SEGGER J-Link 驱动软件 – 

Olimex Debug Driver Olimex 调试仿真器驱动软件 
执行文件
GMD\driver\zadig-2.5.exe 

3.3.1 GMD 软件安装流程 

安装 GOWIN MCU Designer 软件，步骤如下： 

1. 双击安装包，选择安装语言（支持简体中文和英文），比如选择简体中文，

单击“OK”，如图 3-1 所示。 

www.gowinsemi.com.cn/prodshow.aspx
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图 3-1 选择安装语言 

 
 

2. 安装向导，单击“下一步”，如图 3-2 所示。 

图 3-2 安装向导 

 
 

3. 许可证协议，单击“我同意”，如图 3-3 所示。 

图 3-3 许可证协议 

 
 

4. 选择组件 MCU Designer，建议默认设置，单击“下一步”，如图 3-4 所

示。 
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图 3-4 选择组件 

 
 

5. 选择安装位置，单击“安装”，默认安装位置 C:\GMD，如图 3-5 所示。 

图 3-5 选择安装位置 

 

注！ 

GOWIN MCU Designer V1.1 版本，安装过程中不可更改安装目录。 

6. MCU Designer 安装进程，请等候，如图 3-6 所示。 
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图 3-6 MCU Designer 安装进程 

 
 

7. MCU Designer 安装完成后，选择是否安装第三方调试仿真器驱动软件

ARM MCU debug driver (SEGGER JLink)。如果选择安装，则开始 ARM 

MCU debug driver (SEGGER JLink)安装进程。如果不选择安装，则完

成 GMD 安装过程。单击“完成”，如图 3-7所示。 

图 3-7 ARM MCU debug driver 安装选择 

 

 

8. 如果选择安装 ARM MCU debug driver (SEGGER JLink)，则开始安装

SEGGER J-Link 驱动软件，单击“Next”，如图 3-8 所示。 
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图 3-8 J-Link 安装向导 

 
 

9. J-Link 驱动安装许可证协议，单击“I Agree”，如图 3-9 所示。 

图 3-9 J-Link 安装许可证协议 

 
 

10. J-Link 驱动组件选择。“Choose destination”选项，请选择“Update 

existing intallation”，其他选项建议默认设置，单击“Install”，如图 3-10

所示。 

图 3-10 J-Link 组件选择 

 
 

11. J-Link 驱动安装完成，单击“Finish”，如图 3-11 所示。 
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图 3-11 J-Link 安装完成 

 
 

3.3.2 Olimex 调试仿真器驱动软件安装流程 

默认使用 Olimex 调试仿真器作为 Gowin_PicoRV32 的软件在线调试仿

真器（或使用 RiscV 指令集架构处理器支持的其他类型的调试仿真器）。 

Olimex 调试仿真器驱动软件，使用在线下载安装方式，请在安装过程中

保持 PC 机联网状态。 

安装 Olimex 调试仿真器驱动软件，步骤如下： 

1. 连接 Olimex 调试仿真器 USB Cable 与 PC 机。 

2. 在 GMD 安装路径 driver 文件夹中，双击 zadig-2.5.exe，打开 Olimex 调

试仿真器驱动软件，如图 3-12 所示。 

图 3-12 Olimex 调试仿真器驱动软件 

 

 

3. 选择菜单栏“Options > List All Devices”选项，如图 3-13 所示。 

图 3-13 配置 List All Devices 选项 
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4. 选择 List All Devices 选项后，可以看到当前 PC 机所有连接的设备，选

择设备“Olimex OpenOCD JTAG ARM-USB-TINY-H (Interface 0)”，如

图 3-14 所示。 

图 3-14 配置设备类型 Interface 0 

 

 

5. 配置驱动类型选项，请选择“libusbK (v3.0.7.0)”，如图 3-15 所示。 

图 3-15 配置驱动类型 

 

 

6. 单击“Install Driver”或“Reinstall Driver”，开始安装 Olimex 调试仿真

器驱动软件，如图 3-16 所示。 

图 3-16 安装 Olimex 调试仿真器驱动软件 

 

注！ 

Olimex 调试仿真器驱动软件，使用在线下载安装方式，请在安装过程中保持 PC 机联网状

态。 

7. Olimex 调试仿真器驱动软件安装进程，请耐心等待，Interface 0 设备安

装成功后，如图 3-17 所示。 
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图 3-17 Interface 0 设备安装成功 

 

 

8. “Olimex OpenOCD JTAG ARM-USB-TINY-H (Interface 0)”安装成功

后，请继续在设备列表中选择设备“Olimex OpenOCD JTAG 

ARM-USB-TINY-H (Interface 1)”，如图 3-18 所示。 

图 3-18 配置设备类型 Interface 1 

 

 

9. 重复执行步骤 5 ~ 7，安装设备“Olimex OpenOCD JTAG 

ARM-USB-TINY-H (Interface 1)”。 

10. 成功安装设备“Olimex OpenOCD JTAG ARM-USB-TINY-H (Interface 0)”

和“Olimex OpenOCD JTAG ARM-USB-TINY-H (Interface 1)”，PC 机

设备管理中可以正常显示 libusbK USB Devices > Olimex OpenOCD 

JTAG ARM-USB-TINY-H (Interface 0)和 Olimex OpenOCD JTAG 

ARM-USB-TINY-H (Interface 1)。 
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4 GOWIN MCU Designer 用户界面 
GOWIN MCU Designer 软件用户界面如图 4-1 所示，主要分为标题栏

（Title Bar）、菜单栏（Menu Bar）、工具栏（Tool Bar）、项目资源管理器视

图（Project Explorer View）、代码编辑器（Code Editor）、控制台视图（Console 

View）、C/C++透视图（C/C++ Perspective）等。 

图 4-1 软件用户界面 

 

4.1 标题栏 

主要显示当前工程的路径、名称及当前打开的文件名称。 

4.2 菜单栏 

主要提供一些常用菜单以及工程所需的启动工具，包括 File、Edit、

Source、Refactor、Navigate、Search、Project、Run、Window 和 Help 菜

单项。 
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4.2.1 File 菜单项 

File 菜单项，如表 4-1 所示。 

表 4-1 File 菜单项 

菜单项 子菜单项 快捷方式 功能描述 

New 

Makefile Project with 
Existing Code 

Alt+Shift+N 

新建包含makefile的C/C++

项目 

C++ Project 新建C++项目 

C Project 新建C项目 

C/C++ Project 新建C/C++项目 

Project… 新建C、C++、C/C++项目 

Convert to a C/C++ 
Project(Adds C/C++ 
Nature) 

非C/C++项目添加C/C++特

征，使能C/C++工具链 

Source File 新建C/C++源码文件 

Header File 新建C/C++头文件 

File from Template 新建C/C++模板文件 

Class 新建C++类结构 

Source Folder 新建源代码文件夹 

Folder 新建文件夹 

Open File… – – 打开已存在文件 

Open Projects from 
File System… 

– – 由文件系统导入项目向导 

Close – Ctrl+W 关闭现行编辑器 

Close All – Ctrl+Shift+W 关闭所有编辑器 

Save – Ctrl+S 保存现行编辑器的内容 

Save As… – – 
以新名称保存现行编辑器

的内容 

Save All – Ctrl+Shift+S 
保存所有编辑器的内容以

及未保存的变更 

Revert – – 
将现行编辑器的内容恢复

为已保存档案中的内容 

Move… – – 移动资源 

Rename… – F2 重命名资源 

Refresh – F5 

以本地档案系统来重新整

理所选元素的内容，如果不

是从特定选项启动，则会重

新整理所有项目。 

Convert Line 
Delimiters To 

Windows – Windows系统格式 

Unix – Unix系统格式 

Print… – Ctrl+P 打印现行编辑器的内容 

Switch Workspace – – 
切换至不同工作台并重启

工作台 

Restart – – 
重启GOWIN MCU 

Designer IDE 
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菜单项 子菜单项 快捷方式 功能描述 

Import… – – 导入项目向导 

Export… – – 导出项目向导 

Properties – Alt+Enter 项目属性配置 

Exit – – 
退出GOWIN MCU 

Designer IDE 

4.2.2 Edit 菜单项 

Edit 菜单项，如表 4-2 所示。 

表 4-2 Edit 菜单项 

菜单项 快捷方式 功能描述 

Undo Ctrl+Z 恢复为编辑器中的前一次变更 

Redo Ctrl+Y 恢复已取消的变更 

Cut Ctrl+X 剪切 

Copy Ctrl+C 复制 

Paste Ctrl+V 粘贴 

Delete Delete 删除选定文本或元素选项 

Select All Ctrl+A 选择所有的编辑器内容 

Find/Replace Ctrl+F 查找/替换 

Find Word - 查找目前所选文字 

Find Next Ctrl+K 查找目前所选文字的下一个搜寻结果 

Find Previous Ctrl+Shift+K 查找目前所选文字的上一个搜寻结果 

Incremental Find 
Next 

Ctrl+J 
启动增量查找模式，增量查找下一个搜寻结

果。 

Incremental Find 
Previous 

Ctrl+Shift+J 
启动增量查找模式，增量查找上一个搜寻结

果。 

Add Bookmark… – 为目前所选文字或元素新增书签 

Add Task… – 
为目前所选文字或元素新增使用者定义的作

业 

Show Tooltip 
Description 

F2 以浮动说明方式显示现行光标位置上的值 

Content Assist Alt+/ 
现行光标位置开启内容辅助对话框，显示程

序代码辅助语法范本 

Quick Fix Ctrl+1 

如果光标位于出现问题的位置，则在现行光

标位置开启内容辅助对话框，提供可能的更

正方法。 

Parameter Hints Alt+? 
如果光标位于方法参照的参数位置，则以浮

动说明的方式显示参数类型信息。 

Set Encoding - 切换目前所示文字内容的编码 
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4.2.3 Source 菜单项 

Source 菜单项，如表 4-3 所示。 

表 4-3 Source 菜单项 

菜单项 快捷方式 功能描述 

Toggle Comment Ctrl+7 标注出内含现行选择项的所有字行 

Add Block Comment Ctrl+Shift+/ 标注出内含现行选择项的区块 

Remove Block Comment Ctrl+Shift+\ 取消标注内含现行选择项的区块 

Shift Right – 增加目前所选字行的内缩层次 

Shift Left Shift+Tab 减少目前所选字行的内缩层次 

Correct Indentation Ctrl+I 缩进规则应用到目前所选字行 

Format Ctrl+Shift+F 
可使用程序代码格式制作器来设定目前文字

选择项的格式 

Add Include Ctrl+Shift+N 为目前所选的类型参照建立引用 

Organize Includes Ctrl+Shfit+O 为目前所选的编译单元建立引用 

Sort Lines Ctrl+Shift+S 根据指定次序，排序类型中的成员。 

Implement Method… – 置换或实现现行类型中的方法 

Generate Getters and 
Setters… 

– 为现行类型中的字段建立 Getters 和 Setters 

Surround With Alt+Shift+Z 
针对所选的陈述式，评估所有必须捕获到的异

常状况。 

4.2.4 Refactor 菜单项 

Refactor 菜单项，如表 4-4 所示。 

表 4-4 Refactor 菜单项 

菜单项 快捷方式 功能描述 

Rename… Alt+Shift+R 
重新命名所选的元素，并且更新元素的所有

参照。 

Extract Local Variable Alt+Shift+L 
建立新变量，指定给目前所选的表达式，并

将选择项替换为新变量的参照。 

Extract Constant… Alt+C 

从所选表达式中建立 static final 字段并替换

字段参照，重新写入其他出现相同表达式的

位置。 

Extract Function… Alt+Shift+M 
建立新函数，指定给目前所选的语句，并将

选择项替换为新函数的参照。 

Toggle Function Alt+Shift+T 
将选定的函数定义从头文件（类定义的内部

或外部）移动到实现文件，或返回。 

Hide Method… – 私有化选择的方法 

Apply Script… – 应用已保存的重构列表 

Create Script… – 导出已完成的重构列表，供后续使用。 

History… – 显示重构历史记录 

4.2.5 Navigate 菜单项 

Navigate 菜单项，如表 4-5 所示。 
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表 4-5 Navigate 菜单项 

菜单项 子菜单项 快捷方式 功能描述 

Go Into – – 将视图输入设定在当前所选的元素上 

Go To 

Back – 
上一页：将视图输入设定在历程中的上一

个输入上。 

Forward – 
下一页：将视图输入设定在历程中的下一

个输入上。 

Up One 
Level 

– 
往上移一层：将现行视图的输入设定在输

入的母元素上。 

Resource… – 浏览以找出资源，并在现行视图中显示。 

Open Declaration – F3 
显示Open Declaraction选择对话框，以

便在编辑器中开启一个声明。 

Open Type 
Hierarchy 

– F4 
解析现行程序代码选项上所参照的元素，

并在Type Hierarchy视图中开启该元素。 

Open Call 
Hierarchy 

– Ctrl+Alt+H 

开启呼叫现行程序代码选项上所参照的

元素，并在Call Hierarchy视图中开启该

元素。 

Open Include 
Browser 

– Ctrl+Alt+I 显示Include Browser对话框 

Open Element… – Ctrl+Shift+T 
显示Open Element选择对话框，以便在

编辑器中开启一个元素 

Open Type In 
Hierarchy… 

– Ctrl+Shift+H 

显示Open Type选择对话框，以便在编辑

器与Type Hierarchy视图中开启一个类

型。 

Open Element in 
Call Hierarchy… 

– – 

显示Open Element选择对话框，以便在

编辑器与Call Hierarchy视图中开启一个

元素。 

Open Resource… – Ctrl+Shift+R 显示所有资源 

Show In 

Problem 
Details 

Alt+Shift+W 

显示Problem Details视图 

Include 
Browser 

显示Include Browser视图 

C/C++ 
Projects 

显示C/C++ Projects视图 

Project 
Explorer 

显示Project Explorer视图 

System 
Explorer 

显示System Explorer视图 

Properties 显示Properties视图 

Quick Outline - Ctrl+O 为目前选取的类型开启Quick Outline 

Next Annotation – Ctrl+. 选取下一个问题 

Previous 
Annotation 

– Ctrl+, 选取上一个问题 

Last Edit Location – Ctrl+Q 显示前次发生编辑的位置 

Go to Line… - Ctrl+L 
开启对话框，以输入指示编辑器应移至的

行号。 

Back – Alt+Left 
导航至之前在编辑器中检视的前一个资

源 

Forward – Alt+Right 导航并恢复之前的指令所造成的效果 



4 GOWIN MCU Designer 用户界面 4.2 菜单栏 

 

SUG549-1.4 19(29) 

 

4.2.6 Search 菜单项 

Search 菜单项，如表 4-6 所示。 

表 4-6 Search 菜单项 

菜单项 子菜单项 快捷方式 功能描述 

Search… – Ctrl+H 搜索 

File… – – 搜索 File 

C/C++… – – 搜索 C/C++ 

Remote… – – 搜索 Remote 

Text 

Workspace Ctrl+Alt+G 在整个工作区搜索所选元素 

Project – 
在包含所选元素的项目中搜

索所选元素 

File – 
在包含所选元素的文件中搜

索所选元素 

Working Set… – 在工作集中搜索所选元素 

4.2.7 Project 菜单项 

Project 菜单项，如表 4-7 所示。 

表 4-7 Project 菜单项 

菜单项 子菜单项 快捷方式 功能描述 

Open Project – – 
显示对话框，选取开启

已关闭的项目。 

Close Project – – 
关闭目前所选取的项

目 

Build All – Ctrl+B 
对工作台中的所有项

目执行增量编译 

Build Configurations 

Set Active – 
设置Release或Debug

为活动状态 

Manage… – 管理配置 

Build by Working Set – 设置编译工作集 

Set Active by Working Set – 
设置工作集为活动状

态 

Manage Working Sets… – 管理工作集 

Build Project – – 
对目前选取的项目执

行增量编译 

Build Working Set Select Working Set – 
对工作集中的所有项

目执行增量编译 

Clean… – – 清除编译结果 

Build Automatically – – 
自动编译工作区中的

所有项目 

Build Targets 

Create… – 创建 

Build… Shift+F9 编译 

Rebuild Last Target – 重新编译最近目标 

Properties – – 属性配置 
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4.2.8  Run 菜单项 

Run 菜单项，如表 4-8 所示。 

表 4-8 Run 菜单项 

菜单项 快捷方式 功能描述 

Programmer - 启动下载软件 Programmer 

Debug F11 启动调试模式 

Debug History – 使用历史记录中最后一次的调试配置 

Debug As – 启动调试对话框的快捷方式 

Debug Configuration… – 配置调试选项并启动调试 

Toggle Breakpoint Ctrl+Shift+B 根据当前内容，新增或移除断点。 

Toggle Line Breakpoint – 当前可执行代码行，新增或移除断点。 

Toggle Method Breakpoint – 根据当前二进制方法，新增或移除断点。 

Toggle Watchpoint – 当前字段，新增或移除观察点。 

Skip All Breakpoints – 忽略工作区所有断点 

Remove All Breakpoint Ctrl+Alt+B 永久删除工作区所有断点 

Breakpoint Types – 
配置断点类型（C/C++ Breakpoint 或 C/C++ 

Dynamic Printf） 

4.2.9  Window 菜单项 

Window 菜单项，如表 4-9 所示。 

表 4-9 Window 菜单项 

菜单项 子菜单项 快捷方式 功能描述 

New Window – – 
开启一个新的工作台窗口，其中含有

与现行透视图相同的透视图 

Edit 

Toggle Split Editor (Horizontal) Ctrl+_ 横向打开活动编辑器新副本 

Toggle Split Editor (Vertical) Ctrl+( 垂直打开活动编辑器新副本 

Clone – 复制活动编辑器新副本 

Appearance 
Hide Toolbar – 隐藏工具栏 

Toggle Full Screen Alt+F11 全屏开关 

Show View 

Build Targets – 当前透视图中显示 Build Targets 视图 

C/C++ Projects – 
当前透视图中显示 C/C++ Projects 视

图 

Console Alt+Shift+Q,C 当前透视图中显示 Console 视图 
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菜单项 子菜单项 快捷方式 功能描述 

Documents – 当前透视图中显示 Documents 

Include Browser – 
当前透视图中显示 Include Browser

视图 

Navigator – 当前透视图中显示 Navigator 

Outline Alt+Shift+Q,O 当前透视图中显示 Outline 

Problem Details – 
当前透视图中显示Problem Details视

图 

Problems Alt+Shift+Q,X 当前透视图中显示 Problems 视图 

Project Explorer – 
当前透视图中显示 Project Explorer

视图 

Properties – 当前透视图中显示 Properties 视图 

Search Alt+Shift+Q,S 当前透视图中显示 Search 视图 

Tasks – 当前透视图中显示 Tasks 视图 

Other… Alt+Shift+Q,Q 打开所有视图 

Perspective 

Open Perspective – 打开子菜单透视图 

Customize Perspective … – 更改当前透视图各种元素可见性 

Save Perspective As… – 将当前透视图另存为新名称 

Reset Perspective… – 删除自定义透视图 

Close Perspective – 关闭活动透视图 

Close All Perspectives – 关闭所有透视图 

Navigation 

Show System Menu Alt+- 显示系统菜单 

Show View Menu – 显示视图菜单 

Quick Access Ctrl+3 开启快速访问通道 

Maximize Active View or Editor Ctrl+M 最大化当前视图或编辑器 

Minimize Active View or Editor – 最小化当前视图或编辑器 

Active Editor F12 启动编辑器 

Next Editor Ctrl+F6 
启动最近使用的编辑器清单中的下一

个开启的编辑器 

Previous Editor Ctrl+Shift+F6 
启动最近使用的编辑器清单中的上一

个开启的编辑器 

Switch to Editor… Ctrl+Shift+E 切换到已开启的编辑器 

Next View Ctrl+F7 启动最近使用的视图清单中的下一个
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菜单项 子菜单项 快捷方式 功能描述 

开启的视图 

Previous View Ctrl+Shift+F7 
启动最近使用的视图清单中的上一个

开启的视图 

Next Perspective Ctrl+F8 
启动最近使用的透视图清单中的下一

个开启的透视图 

Previous Perspective Ctrl+Shift+F8 
启动最近使用的透视图清单中的上一

个开启的透视图 

Preferences – – 配置当前工作台选项 

4.2.10 Help 菜单项 

Help 菜单项，如表 4-10 所示。 

表 4-10 Help 菜单项 

菜单项 快捷方式 功能描述 

Welcome – 显示欢迎使用视图 

Help Contents – 显示帮助说明视图 

Search – 搜索 Help 内容 

Show Contextual Help – 显示 Related Topic 中的 Help 内容 

Show Active Keybindings… Ctrl+Shift+L 显示活动的快捷键 

Tips and Tricks… – 开启尚未探索的生产力特性列表 

Cheat Sheets… – 开启选取提要的对话框 

License Content - 显示 License 信息 

About Gowin MCU Designer  显示 GOWIN MCU Designer 信息 

 

单击菜单栏“Help > Help Contents”，可以查看 GMD、

Gowin_EMPU(GW1NS-2C)、Gowin_EMPU(GW1NS-4C)、

Gowin_EMPU_M1、Gowin_EMPU_M3、Gowin_PicoRV32 等用户手册，如

图 4-2 所示。 
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图 4-2 Help Contents 

 

4.3 工具栏 

主要提供一些常用功能的快速访问入口，主要包括：新建文件或工程

（New）、保存文件（Save）、保存所有文件（Save All）、配置管理（Manage 

Configuration）、编译（Build/Build All）、下载（Programmer）、调试（Debug）、

搜索（Search）等，如表 4-11 所示。 

表 4-11 工具栏选项 

工具栏选项 选项标志 功能描述 

New  新建项目工程、文件 

Save  保存现行编辑器的内容 

Save All  以新名称保存现行编辑器的内容 

Manage Configurations  配置管理（包括 Debug 和 Release） 

Build  对目前选取的项目执行增量编译 

Build All 
 

对工作台中的所有项目执行增量编译 

Skip All Breakpoints 
 调试过程中忽略工作区所有断点 

Restart  重启 GOWIN MCU Designer IDE 

Make the C/C++ Packs 
perspective visible  

加载 ARM 处理器器件信息 
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工具栏选项 选项标志 功能描述 

Debug  调试 

Programmer  启动 Programmer 下载 

Open Element  
显示 Open Element 选择对话框，以便

在编辑器中开启一个元素 

Search  搜索 

Toggle Mark Occurrences  开关 C/C++编辑器标记事件 

Toggle Work Wrap 
 

开关自动换行 

Toggle Block Selection Mode 
 

开关模块选择模式 

Show Whitespace Characters  编辑器中显示空白字符 

Next Annotation  选取下一个问题 

Previous Annotation  选取上一个问题 

Last Edit Location 
 

显示前次发生编辑的位置 

Back  
导航至之前在编辑器中检视的前一个

资源 

Forward  导航并恢复之前的指令所造成的效果 

4.4 项目资源管理器视图 

主要提供工程及其相关文件的管理和显示功能，主要显示或更改工程用

户设计文件。 

4.5 代码编辑器 

提供基本的文件编辑及查看功能。 

在 File 窗口新建或打开的文件可显示在文本编辑区。 

单击菜单栏“File > Close”选项或文本编辑区当前显示文件名右侧

“ ”，会关闭文本编辑区内当前显示的文件。 

单击菜单栏“File > Close All”选项，则会关闭文本编辑区内显示的所

有文件。 

4.6 控制台视图 

显示软件在运行过程中处理信息，可手动切换标签页查看不同类型的输

出信息： 

 控制台信息页（Console 页） 

 问题信息页（Problems 页） 
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5 License 管理 

5.1 License 申请 

GOWIN MCU Designer安装完成后首次启动，会提示安装注册License，

GOWIN MCU Designer 首次启动前，联系高云 FAE 或当地办事处，申请

License。 

申请 License，请提供如下信息： 

 计算机 MAC 地址（必选） 

 计算机名称（可选） 

5.2 License 安装 

GOWIN MCU Designer 安装完成后首次启动，弹出配置 License 对话框，

提示用户安装注册 License，如图 5-1 所示。 

图 5-1 启动 License 提示 

 
 

如果没有申请 License，单击“Exit”，请与高云 FAE 或当地办事处联系，

申请 License。 



5 License 管理 5.3License 管理 

 

SUG549-1.4 26(29) 

 

如果已申请 License，单击“Install now”，导入已获取的 License 文件，

单击“OK”，如图 5-2 所示。 

图 5-2 License 安装注册 

 
 

如图 5-3 所示，License 安装注册完成后，提示 License 安装验证成功，

单击“OK”，启动 GOWIN MCU Designer。 

图 5-3 License 验证 

 

5.3 License 管理 

License 到期前，可申请新的 License 进行重新安装注册。 

单击菜单栏“Window > Perferences”，打开 Perferences 对话框，选择
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“License > Manage”，可以重新安装注册新的 License 文件，如图 5-4 所

示。 

图 5-4 License 管理 

 

5.4 License 查看 

安装注册License并验证成功后，单击菜单栏“Help > License Content”，

可以查看已安装注册的 License 信息，如图 5-5 所示。 

图 5-5 License 查看 

 



6 GOWIN MCU Designer 软件使用 6.1 编译工具链配置 

 

SUG549-1.4 28(29) 

 

6 GOWIN MCU Designer 软件使用 

6.1 编译工具链配置 

6.1.1 ARM MCU 编译工具链配置 

创建 ARM MCU 项目工程时，单击菜单栏“File > New > C Project”或

工具栏“New > C Project”，打开 New C Project 对话框。“Project type”选

择“Empty Project”，“Toolchains”选择“ARM Cross GCC”，如图 6-1 所

示。 

图 6-1 ARM MCU 编译工具链配置 

 

6.1.2 RISC-V MCU 编译工具链配置 

创建 RISC-V MCU 项目工程时，单击菜单栏“File > New > C Project”

或工具栏“New > C Project”，打开 New C Project 对话框。“Project type”

选择“Empty Project”，“Toolchains”选择“RISC-V Cross GCC”，如图 6-2

所示。 
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图 6-2 RISC-V MCU 编译工具链配置 

 

6.2 参考手册 

GOWIN MCU Designer 软件使用，请参考用户手册： 

 IPUG519，Gowin_EMPU(GW1NS-2C) IDE 软件参考手册 

 IPUG536，Gowin_EMPU_M1 IDE 软件参考手册 

 IPUG928，Gowin_EMPU(GW1NS-4C) IDE 软件参考手册 

 IPUG919，Gowin_EMPU_M3 IDE 软件参考手册 

 IPUG910，Gowin_PicoRV32 IDE 软件参考手册 

http://cdn.gowinsemi.com.cn/IPUG519.pdf
http://cdn.gowinsemi.com.cn/IPUG536.pdf
http://cdn.gowinsemi.com.cn/IPUG928.pdf
http://cdn.gowinsemi.com.cn/IPUG919.pdf
http://cdn.gowinsemi.com.cn/IPUG910.pdf
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