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1 About This Guide 

1.1 Purpose 
This manual describes GOWIN MCU Designer (GMD) installation and 

operation and aims to help users learn the software functions to improve 
design efficiency. The software screenshots and the supported products 
listed in this manual are based on GOWIN MCU Designer V1.2. As the 
software is subject to change without notice, some information may not 
remain relevant and may need to be adjusted according to the software 
that is in use. 

1.2 Related Documents 
The latest user guides are available on GOWINSEMI Website. You 

can find the related documents at www.gowinsemi.com: 

 IPUG536, Gowin_EMPU_M1 IDE Software Reference Manual 

 IPUG928, Gowin_EMPU(GW1NS-4C) IDE Software Reference 
Manual 

 IPUG919, Gowin_EMPU_M3 IDE Software Reference Manual 

 IPUG910, Gowin_PicoRV32 IDE Software Reference Manual 

1.3 Terminology and Abbreviation 
Table 1-1 shows the abbreviations and terminology used in this 

manual. 

Table 1-1 Terminology and Abbreviations 

Terminology and Abbreviation Full Name 

ARM Advanced RISC Machine 

FPGA Field-Programmable Gate Array 

IDE Integrated Development Environment 

GCC GNU Compiler Collection 

GDB GNU Debug 

GMD GOWIN MCU Designer 

GNU GNU is Not Unix 

http://www.gowinsemi.com/
http://cdn.gowinsemi.com.cn/IPUG536E.pdf
http://cdn.gowinsemi.com.cn/IPUG928E.pdf
http://cdn.gowinsemi.com.cn/IPUG928E.pdf
http://cdn.gowinsemi.com.cn/IPUG919E.pdf
http://cdn.gowinsemi.com.cn/IPUG910E.pdf
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Terminology and Abbreviation Full Name 

MCU Microcontroller Unit 

OpenOCD Open On-Chip Debugger 

PC Personal Computer 

RISC Reduced Instruction-Set Computer 

RISC-V RISC Five 

1.4 Support and Feedback 
Gowin Semiconductor provides customers with comprehensive 

technical support. If you have any questions, comments, or suggestions, 
please feel free to contact us directly by the following ways: 

Website: www.gowinsemi.com 

E-mail: support@gowinsemi.com 

http://www.gowinsemi.com/
file:///C:/Users/Yanan/AppData/Roaming/Microsoft/Word/support@gowinsemi.com
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2 GMD Software Overview 

2.1 Introduction 
GMD is a new generation of MCU software development environment 

designed in-house by GOWIN according to its own FPGA+MCU SoC 
architecture features. It's based on GNU GCC compilation toolchain and 
open source Eclipse framework. It supports C/C++ embedded software 
programming language and helps users to quickly implement code 
compilation and linking, generate mapping files and download, etc. GND 
also integrates an on-line debugging tool for users to quickly locate and 
analyze software programming issues. 

GMD supports the MCU compilation toolchain of ARM architecture 
and RISC-V architecture and also supports MCU compilation, linking, 
downloading and debugging of ARM Cortex-M1, ARM Cortex-M3 and 
RISC-V architecture. 

GMD provides a GUI for projects. Users can employ this software to 
quickly edit codes, check the running results, and start the GOWINSEMI 
FPGA download tool immediately to download the mapping file to the chip 
and implement the required functions. GMD GUI is as shown in Figure 2-1. 
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Figure 2-1 GMD Software Interface 

 

2.2 Processors Supported 
The processors, architectures, and chips that GMD supports are listed 

in Table 2-1. 

Table 2-1 Processors Supported by GMD 

Processor Architecture Chip 

Gowin_EMPU (GW1NS-4C) ARM Cortex-M3 

 GW1NS-4C 

 GW1NSR-4C 

 GW1NRSER-4C 

Gowin_EMPU_M1 ARM Cortex-M1 

 GW1N-9 

 GW1NR-9 

 GW1N-9 Version C 

 GW1NR-9 Version C 

 GW2A-18 

 GW2AR-18 

 GW2A-18 Version C 

 GW2AR-18 Version C 

 GW2ANR-18 Version C 

 GW2A-55 

 GW2A-55 Version C 

 GW2AN-18X 

 GW2AN-9X 

 GW2AN-55 Version C 

 GW5AT-138 Version B 

 GW5AST-138 Version B 

Gowin_EMPU_M3 ARM Cortex-M3 

 GW2A-55 

 GW2A-55 Version C 

 GW2AN-55 Version C 
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Processor Architecture Chip 

Gowin_PicoRV32 RISC-V 

 GW1N-9 

 GW1NR-9 

 GW1N-9 Version C 

 GW1NR-9 Version C 

 GW2A-18 

 GW2AR-18 

 GW2A-18 Version C 

 GW2AR-18 Version C 

 GW2ANR-18 Version C 

 GW2A-55 

 GW2A-55 Version C 

 GW2AN-18X 

 GW2AN-9X 

 GW2AN-55 Version C 

Note! 

The supported processors may vary according to the software version in use. Please refer 
to the software you use for more detailed processor information. 
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3 Install GMD Software 

3.1 Environment Requirement 
Windows: Win7/8/10(64bit) 

3.2 Software Download 
You can download GMD installation package (GMD_V1.2.exe) via 

Gowin official website: https://www.gowinsemi.com/en/support/database 

Note! 

Users need to register and log on to the Gowin website before downloading the installation 
package; 

3.3 Software Installation 
Note! 

 You must close anti-virus programs, such as 360 or Kingsoft AntiVirus, etc. before 
installing GMD. 

 The installation path should not contain any Chinese characters or spaces. 
 Before installing any new versions of GMD, old versions should be uninstalled. 
 Table 3-1 shows the product options for the installation of GOWIN MCU Designer. 

Table 3-1 Components to Install 

Components Description MCU Supported Remarks 

GMD Framework GMD frame – 
Executable file: 
GMD_V1.2.exe 

SEGGER J-Link 
Debugger Driver 

SEGGER J-LINK 
debugger driver software 

ARM Cortex M1 and 
M3 

– 

Olimex Debugger 
Driver 

Olimex debugger driver 
software 

RISC-V – 

 
The steps of installing GMD Software is as follows:  

1. Double click the installation package to open the wizard; click "Next", 
as shown in Figure 3-1.  

https://www.gowinsemi.com/en/support/database/569/?support_search=GOWIN+MCU+Designer
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Figure 3-1 Wizard 

 
 

2. Click "I Agree", as shown in Figure 3-2. 

Figure 3-2 License Agreement 

 
 

3. Select "Framework", and click "Next", as shown in Figure 3-3. 
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Figure 3-3 Choose Components 

 
 

4. Select the installation path, and the default path C:\GMD is 
recommended; click "Install", as shown in Figure 3-4. 

Figure 3-4 Choose Installation Location 

 
 

5. The installation process is as shown in Figure 3-5. 
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Figure 3-5 Installing 

 
 

6. After installing GMD, select whether to install Arm Debugger Driver 
(J-Link) and RiscV Debugger Driver (Olimex). If you choose to install, 
you can go on; if you do not choose to install, the GMD installation is 
completed. Click "Finish", as shown in Figure 3-6. 

Figure 3-6 Debug Driver Installation Option 

 

 

7. If you choose "Install Arm Debugger Driver (J-Link)", then J-Link wizard 
pops up. Click "Next", as shown in Figure 3-7. 
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Figure 3-7 J-Link Wizard 

 
 

8. Figure 3-8 shows the license agreement, and click "I Agree". 

Figure 3-8 J-Link Installation License Agreement 

 
 

9. Select J-Link driver components. select "Update existing installation" in 
"Choose destination" option. Default settings are recommended. Click 
"Install", as shown in Figure 3-9. 

Figure 3-9 J-Link Components Selection 

 
 

10. Click "Finish" when J-Link driver installation is completed, as shown in 
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Figure 3-10 

Figure 3-10 J-Link Installation Complete 

 
 

11. If you select "Install RiscV Debugger Driver (Olimex)" in step 6, the 
Olimex driver software installation wizard pops up, as shown in Figure 
3-11. 

Figure 3-11 Olimex Debugger Driver 

 
Note！ 

Make sure that the Olimex debugger is connected to PC before the driver installation. 

12. Select "Options > List All Devices" in the menu bar, as shown in Figure 
3-12. 

Figure 3-12 Configure List All Devices  

 
 

13. After selecting "List All Devices", you can see all the devices connected 
to the PC, select "Olimex OpenOCD JTAG ARM-USB-TINY-H 
(Interface 0)", as shown in Figure 3-13.  
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Figure 3-13 Olimex OpenOCD JTAG ARM-USB-TINY-H (Interface 0) 

 
 

14. Select the driver type "libusbK (v3.0.7.0)", as shown in Figure 3-14.  

Figure 3-14 Driver Type 

 
 

15. Click "Install Driver" or "Reinstall Driver" to start installing Olimex 
Debugger Driver software, as shown in Figure 3-15. 

Figure 3-15 Install Olimex Debugger Driver Software 

 
 

16. Figure 3-16 shows the Olimex degugger driver software installation 
process, and the Interface 0 device is successfully installed. 

Figure 3-16 Interface 0 Device Installation Successful 
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17. After "Olimex OpenOCD JTAG ARM-USB-TINY-H (Interface 0)" is 
installed successfully, please continue to select "Olimex OpenOCD 
JTAG ARM-USB-TINY-H (Interface 1)" in the list of devices, as shown 
in Figure 3-17. 

Figure 3-17 Configure Interface 1 

 

 

18. Repeat steps 5 to 7 to install "Olimex OpenOCD JTAG 
ARM-USB-TINY-H (Interface 1)". 

19. After "Olimex OpenOCD JTAG ARM-USB-TINY-H (Interface 0)" and 
"Olimex OpenOCD JTAG ARM-USB-TINY-H (Interface 1)" are installed 
successfully, " libusbK USB Devices > Olimex OpenOCD JTAG 
ARM-USB-TINY-H (Interface 0)" and " Olimex OpenOCD JTAG 
ARM-USB-TINY-H (Interface 1)" can be displayed in the PC device 
management.  
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4 GMD Software GUI 
Figure 4-1 shows GMD software GUI. It consists of the title bar, menu 

bar, tool bar, Project Explorer View, Code Editor, Console View, C/C++ 
Perspective, etc. 

Figure 4-1 GUI 

 

4.1 Title Bar 
Title bar shows the current project path, name, and the name of the file 

that is currently open. 

4.2 Menu Bar 
Menu bar provides common used menus and start tools for projects, 

including the options of File, Edit, Source, Refactor, Navigate, Search, 
Project, Run, Window, and Help. See the following for details. 
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4.2.1 File 

The file menu is as shown in Table 4-1. 

Table 4-1 File Menu 

Menu Item Sub-menu Item Shortcut Functional Description 

New 

Makefile Project with 
Existing Code 

Alt+Shift+N 

Create C/C++ project 
containing makefile 

C++ Project Create C++ project 

C Project Create C project 

C/C++ Project Create C/C++ project 

Project… Create C, C++, C/C++project 

Convert to a C/C++ 
Project (Adds C/C++ 
Nature) 

None-C/C++ project 
addsC/C++ features, C/C++ 
tool chain enable 

Source File Create C/C++ source file 

Header File Create C/C++ header file 

File from Template Create C/C++ template file 

Class Create C/C++ class structure 

Source Folder Create a source folder 

Folder Create a folder 

Open File… – – Open the existed file 

Open Projects from File 
System… 

– – 
Import the project wizard from 
file system 

Close – Ctrl+W Close the active editor 

Close All – Ctrl+Shift+W Close all editors 

Save – Ctrl+S 
Save the content of the active 
editor 

Save As… – – 
Save the content of the active 
editor under a new name 

Save All – Ctrl+Shift+S 
Save all editor's content and 
the unsaved changes 

Revert – – 
Revert the content of the 
active editor as the saved 
content 

Move… – – Move resources 

Rename… – F2 Rename resources 

Refresh – F5 

Refresh selected elements 
based on local file system (If 
not started from the specified 
option, refresh all) 

Convert Line Delimiters 
To 

Windows – Windows system format 

Unix – Unix system format 

Print… – Ctrl+P 
Print the content of the active 
editor 

Switch Workspace – – 
Switch workspace and restart 
workspace 

Restart – – Restart GMD 
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Menu Item Sub-menu Item Shortcut Functional Description 

Import… – – Import the project wizard 

Export… – – Export the project wizard 

Properties – Alt+Enter Properities configuration 

Exit – – Exit GMD  

4.2.2 Edit 

The edit menu is as shown in Table 4-2. 

Table 4-2 Edit Menu 

Menu Item Shortcut Functional Description 

Undo Ctrl+Z Undo the previous step 

Redo Ctrl+Y Redo the cancelled changes 

Cut Ctrl+X Cut 

Copy Ctrl+C Copy 

Paste Ctrl+V Paste 

Delete Delete Delete the selected text or element option 

Select All Ctrl+A Select all the editor's content 

Find/Replace Ctrl+F Find/Replace 

Find Word - Find the selected word 

Find Next Ctrl+K 
Find the next word of the current selected 
text 

Find Previous Ctrl+Shift+K 
Find the previous word of the current 
selected 

Incremental Find 
Next 

Ctrl+J Start incremental find mode to find the next 

Incremental Find 
Previous 

Ctrl+Shift+J 
Start incremental find mode to find the 
previous 

Add Bookmark… – 
Add bookmark to the current selected text 
or elements 

Add Task… – 
Add user-defined task to the current 
selected text or elements 

Show Tooltip 
Description 

F2 
Display the value of the current cursor 
position as floating instructions 

Content Assist Alt+/ 
Open content assist view at the current 
cursor position to display the auxiliary 
syntax sample of the programming code 

Quick Fix Ctrl+1 

If the cursor is at the location of the 
problem, the content assist view will be 
opened and the possible corrections will be 
provided. 

Parameter Hints Alt+? 

If the cursor is at the location of the 
referential parameters, the parameter 
information will be displayed as floating 
instructions 

Set Encoding - Switch the current content coding 
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4.2.3 Source 

The source menu is as shown in Table 4-3. 

Table 4-3 Source Menu 

Menu Item Shortcut Functional Description 

Toggle Comment Ctrl+7 
Toggle comment on all lines containing the 
selected text of the current line 

Add Block Comment Ctrl+Shift+/ 
Comment on all blocks containing the selected 
text of the current line 

Remove Block Comment Ctrl+Shift+\ 
Remove the blocks containing the selected text of 
the current line 

Shift Right – Increase indent in the selected line 

Shift Left Shift+Tab Reduce indent in the selected line 

Correct Indentation Ctrl+I Indent rule applying to the selected line 

Format Ctrl+Shift+F 
Program code formatter can be used to format 
the current text selection 

Add Include Ctrl+Shift+N Add include to the reference of the selected type 

Organize Includes Ctrl+Shfit+O Add Include to the selected compilation organizes 

Sort Lines Ctrl+Shift+S Sort lines according to the specified order 

Implement Method… – 
The method of replacing or implementing the 
current type 

Generate Getters and 
Setters… 

– 
Generate Getters and Setters for the field of the 
current line type 

Surround With Alt+Shift+Z 
Evaluate all exceptions that must be caught for 
the selected statement 

4.2.4 Refactor 

The Refactor menu is as shown in Table 4-4. 

Table 4-4 Refactor Menu 

Menu Item Shortcut Functional Description 

Rename… Alt+Shift+R 
Rename the selected element and update all the 
reference of  the elements 

Extract Local Variable Alt+Shift+L 
Create a new variable and specify it to the selected 
expression and replace the selected as the new 
variable's reference 

Extract Constant… Alt+C 
Creates the static final field from the selected expression 
and replaces the field reference, rewriting to the other 
locations where the same expression occurs 

Extract Function… Alt+Shift+M 
Create a new variable and specify it to the selected 
statement and replace the selected as the new variable's 
reference 

Toggle Function Alt+Shift+T 
Move the selected function from the header file to the 
implementation file or return 

Hide Method… – Hide Method… 

Apply Script… – Apply the saved refactor list 

Create Script… – Export the refactor list for later use 
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Menu Item Shortcut Functional Description 

History… – Display the refactor history 

4.2.5 Navigate 

The Navigate menu is listed in Table 4-5. 

Table 4-5 Navigate Menu 

Menu Item Sub-menu Item Shortcut Functional Description 

Go Into – – 
Set the view input to the current selected 
element 

Go To 

Back – Back: Set the view input to the previous input 

Forward – Forward: Set the view input to the next input 

Up One Level – 
Up One Level: Set the current view input to the 
input parent element 

Resource… – 
Browse to find resources and display them in 
the current view 

Open Declaration – F3 
Display the Open Declaraction view to open a 
declaration in the editor 

Open Type 
Hierarchy 

– F4 
Parse the element referenced by the current 
program code options and open it in the Type 
Hierarchy view 

Open Call 
Hierarchy 

– Ctrl+Alt+H 
Open Call the element referenced by the current 
program code options and open it in the Call 
Hierarchy view 

Open Include 
Browser 

– Ctrl+Alt+I Display Include Browser 

Open Element… – Ctrl+Shift+T 
Display the Open Element view to open an 
element in the editor 

Open Type In 
Hierarchy… 

– Ctrl+Shift+H 
Display the Open Type view to open a type in 
the editor and Type Hierarchy view 

Open Element in 
Call Hierarchy… 

– – 
Display the Open Element view to open an 
element in the editor and Call Hierarchy view 

Open Resource… – Ctrl+Shift+R Display all resources 

Show In 

Problem Details 

Alt+Shift+W 

Display Problem Details view 

Include Browser Display Include Browser view 

C/C++ Projects Display C/C++ Projects view 

Project Explorer Display Project Explorer view 

System Explorer Display System Explorer view 

Properties Display Properties view 

Quick Outline - Ctrl+O Open quick outline for the current selected type 

Next Annotation – Ctrl+. Navigate to the next item 

Previous 
Annotation 

– Ctrl+, Navigate to the previous item 

Last Edit Location – Ctrl+Q Display the last edit location 

Go to Line… - Ctrl+L 
Open a dialog box to enter the line number to 
indicate which line the editor should move 
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Menu Item Sub-menu Item Shortcut Functional Description 

Back – Alt+Left 
Navigate to the previous resource that 
previously viewed in the editor 

Forward – Alt+Right 
Navigate and restore the result of previous 
commands 

4.2.6 Search 

The search menu is as shown in Table 4-6. 

Table 4-6 Search Menu 

Menu Item Sub-menu Item Shortcut Functional Description 

Search… – Ctrl+H Search 

File… – – Search File 

C/C++… – – Search C/C++ 

Remote… – – Search Remote 

Text 

Workspace Ctrl+Alt+G 
Search for the selected 
element throughout the 
workspace 

Project – 

Search for the selected 
element in the projects that 
contains the selected 
element 

File – 

Search for the selected 
element in the files that 
contains the selected 
element 

Working Set… – 
Search for the selected 
element in the working set 

4.2.7 Project 

The project menu is as shown in Table 4-7. 

Table 4-7 Project Menu 

Menu Item Sub-menu Item Shortcut Functional Description 

Open Project – – Select to open the closed items 

Close Project – – Close the currently selected items 

Build All – Ctrl+B 
Perform incremental compilation of 
all items in the workspace 

Build Configurations 

Set Active – SetRelease or Debug as active 

Manage… – Manage configuration 

Build by Working Set – Set to build the working set 

Set Active by Working 
Set 

– Set Working Set as active 

Manage Working 
Sets… 

– Manage Working Sets 

Build Project – – 
Perform incremental compilation on 
the selected projects 
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Menu Item Sub-menu Item Shortcut Functional Description 

Build Working Set Select Working Set – 
Perform incremental building of all 
projects in the Working Set 

Clean… – – Clean building results 

Build Automatically – – 
Build all projects in the workspace 
automatically 

Build Targets 

Create… – Create 

Build… Shift+F9 Build 

Rebuild Last Target – Rebuild the last target 

Properties – – Properities configuration 

4.2.8 Run 

The run menu is as shown in Table 4-8. 

Table 4-8 Run Menu 

Menu Item Shortcut Functional Description 

Programmer - Start Gowin Programmer 

Debug F11 Start Debugging mode 

Debug History – Use the last debug configuration in the history 

Debug As – A shortcut to start the debug dialog box 

Debug Configuration… – Configure debug options and start debugging 

Toggle Breakpoint Ctrl+Shift+B Add or remove breakpoints based on the current content 

Toggle Line Breakpoint – 
Add or remove breakpoints of current executable code 
line 

Toggle Method 
Breakpoint 

– 
Add or remove breakpoints based on the current binary 
method 

Toggle Watchpoint – Add or remove watchpoints of current field 

Skip All Breakpoints – Skip all breakpoints in the workspace 

Remove All Breakpoint Ctrl+Alt+B Remove all breakpoints in the workspace Permanently 

Breakpoint Types – 
Configure breakpoint types （C/C++ Breakpoint or C/C++ 

Dynamic Printf） 

4.2.9 Window 

The window menu is as shown in Table 4-9. 

Table 4-9 Window Menu 

Menu Item Sub-menu Item Shortcut Functional Description 

New Window – – 
Open a new workbench window with 
the same perspective as the current 
one 

Edit 

Toggle Split Editor (Horizontal) Ctrl+_ 
Open a new copy of the active editor 
horizontally 

Toggle Split Editor (Vertical) Ctrl+( 
Open a new copy of the active editor 
vertically 

Clone – Copy a new copy of the active editor  
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Menu Item Sub-menu Item Shortcut Functional Description 

Appearance 
Hide Toolbar – Hide Tool bar 

Toggle Full Screen Alt+F11 Full screen toggle 

Show View 

Build Targets – 
Display the Build Targets view in the 
active perspective 

C/C++ Projects – 
Display C/C++ Projects view in the 
active perspective 

Console Alt+Shift+Q,C 
Display Console view in the active 
perspective 

Documents – 
Display documents in the active 
perspective 

Include Browser – 
Display Include Browser view in the 
active perspective 

Navigator – 
Display Navigator in the active 
perspective 

Outline Alt+Shift+Q,O 
Display Outline in the active 
perspective 

Problem Details – 
Display Problem Details view in the 
active perspective 

Problems Alt+Shift+Q,X 
Display Problem view in the active 
perspective 

Project Explorer – 
Display Problem Explorer view in the 
active perspective 

Properties – 
Display Properties view in the active 
perspective 

Search Alt+Shift+Q,S 
Display Search view in the active 
perspective 

Tasks – 
Display Tasks view in the active 
perspective 

Other… Alt+Shift+Q,Q Open all views 

Perspective 

Open Perspective – Open the perspective of sub-menus 

Customize Perspective … – 
Change the visibility of various 
elements in the active perspective 

Save Perspective As… – 
Save the active perspective as a new 
name view 

Reset Perspective… – 
Remove the user-defined 
perspectives 

Close Perspective – Close the active perspective 

Close All Perspectives – Close all perspectives 

Navigation 

Show System Menu Alt+- Show system menu 

Show View Menu – Show vew menu 

Quick Access Ctrl+3 Open quick access 

Maximize Active View or Editor Ctrl+M Maximize active view or editor 

Minimize Active View or Editor – Minimize active view or editor 

Active Editor F12 Start editor 
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Menu Item Sub-menu Item Shortcut Functional Description 

Next Editor Ctrl+F6 
Start the next editor in the list of 
recently used editors 

Previous Editor Ctrl+Shift+F6 
Start the previous editor in the list of 
recently used editors 

Switch to Editor… Ctrl+Shift+E Switch to the open editor 

Next View Ctrl+F7 
Start the next view in the list of 
recently used views 

Previous View Ctrl+Shift+F7 
Start the previous view in the list of 
recently used views 

Next Perspective Ctrl+F8 
Start the next perspective in the list 
of recently used perspectives 

Previous Perspective Ctrl+Shift+F8 
Start the previous perspective in the 
list of recently used perspectives 

Preferences – – 
Configure the preferences for the 
active workspace 

4.2.10 Help 

The Help menu is as shown in Table 4-10. 

Table 4-10 Help Menu 

Menu Item Shortcut Description 

Welcome – Welcome page 

Help Contents – Help page 

Search – Search the Help contents 

Show Contextual Help – Show the Help contents in related topics 

Show Active Keybindings… Ctrl+Shift+L Show active keybindings 

Tips and Tricks… – Tips and Tricks 

Cheat Sheets… – Cheat Sheets… 

License Content - Display license content 

About GOWIN MCU Designer  Display GMD information 

 

Click "Help > Help Contents" on the menu bar to view the user 
manuals of GMD, Gowin_EMPU (GW1NS-4C), Gowin_EMPU_M1, 
Gowin_EMPU_M3, and Gowin_PicoRV32, as shown in Figure 4-2.  
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Figure 4-2 Help Contents 

 

 
Click "Help > About GOWIN MCU Designer" on the menu bar to view 

GMD information, as shown in Figure 4-3. 

Figure 4-3 About GOWIN MCU Designer 
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4.3 Tool Bar 
Tool bar provides quick accesses to some commonly used functions, 

mainly including Build, Run, Stop, New Wizards, Save, Save All, Manage, 
Restart, Debug, Search, etc. as shown in Table 4-11. 

Table 4-11 Tool Bar Options 

Tool Bar Options Icon Functional Description 

New  New a project or a file 

Save  
Save the content of the active 
editor 

Save All  
Save the content of the active 
editor under a new name 

Manage Configurations  
Manage configurations (Debug 
and Release) 

Build…  
Perform incremental compilation 
on the selected projects 

Build All 
 

Perform incremental compilation of 
all items in the workspace 

Skip All Breakpoints  
Skip all breakpoints in the 
workspace during debugging 

Restart  Restart GMD 

Make the C/C++ Packs 
perspective visible  

Load the device information of 
ARM processor 

Debug 
 

Debugging 

Programmer  Start Programmer. 

Open Element  
Display the Open Element view to 
open an element in the editor 

Search  Search 

Toggle Mark Occurrences  
Toggle mark occurrences of C/C++ 
editor 

Toggle Work Wrap 
 

Toggle Work Wrap 

Toggle Block Selection 
Mode  

Toggle Block Selection Mode 

Show Whitespace 
Characters  

Show Whitespace Characters 

Next Annotation  Navigate to the next item 

Previous Annotation  Navigate to the previous item 

Last Edit Location 
 

Display the last edit location 

Back  
Navigate to the previous resource 
that previously viewed in the editor 

Forward  
Navigate and restore the result of 
previous commands 
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4.4 Project Area 
The project area shows projects and the related files. Users can check 

or change the project device information, user design files, etc. 

4.5 Source File Editing Area 
Users can view and edit source files in the source file editing area. 
The newly-built or opened files from the File window will be displayed 

in the source file editing area. 
To close the file currently displayed, click "File > Close" on the menu 

bar or click on the icon " " that appears in the upper-right of the file 
editing area. 

To close all the files in the file editing area, click "File > Close All" on 
the menu bar. 

4.6 Information Output area 
The information output area displays the processing information when 

the software is running. Users can verify different outputs by  
manually switching between the tabs: 

 Console 

 Problems 
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5 License Management 

5.1 License Application 
When users start GMD for the first time after it is installed, the prompt 

for the License installation and registration pops up. Please apply for a 
License before starting GMD for the first time. 

The information as follows is required to apply for a license: 
 MAC address (Mandatory) 
 Computer name (Optional) 

5.2 License Installation 
After GMD is installed and started for the first time, a license 

configuration dialog box pops up, as shown in Figure 5-1. 

Figure 5-1 A Starting License Prompt 

 

 

If users have no License, click "Exit" and apply for a License. 
If users have the License, click "Install now", import the License file, 

and click "OK", as shown in Figure 5-2. 
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Figure 5-2 License Installation 

 

 

As shown in Figure 5-3, when the License installation is complete, 
"License verify successfully!" pops up. Click "OK", and GMD starts. 

Figure 5-3 License Verification 
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5.3 License Management 
Before the License is due to expire, users can apply for a new License 

and reinstall.  
Click Window > Perferences on the menu bar to open the 

"Perferences" view. Select "License > Manage" and import the new 
License file, as shown in Figure 5-4. 

Figure 5-4 License Management 

 

5.4 License Check 
After the License is installed and verified, click "Help > License 

Content" on the menu bar to check the installed License information, as 
shown in Figure 5-5. 

Figure 5-5 License Check 
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6 GMD Software Configuration 

If the default path "C:\GMD" is used, GMD software is configured by 
default and users do not need to configure the toolchain; if you choose 
another path, re-configure the toolchain. 

Click "Window > Perferences" on the menu bar to open the 
Perferences dialog box, configure "Global ARM Toolchains Paths", "Global 
Build Tools Path", "Global OpenOCD Path", "Global RISC-V Toolchain 
Path" and "Global RISC-V Toolchain Path", "Global RISC-V Toolchains 
Paths", and "Global SEGGER J-Link Path" in "MCU" option, as shown in 
Figure 6-1. 

Figure 6-1 Software Toolchains Configuration 
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6.1 Global ARM Toolchains Paths Configuration 
Click "Global ARM Toolchains Paths" to configure ARM MCU software 

toolchain, as shown in Figure 6-2 . 

Figure 6-2 Global ARM Toolchains Paths 

 

6.2 Global Build Tools Path Configuration 
Click "Global Build Tools Path" to configure build software toolchain, 

as shown in Figure 6-3. 

Figure 6-3 Global Build Tools Path 
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6.3 Global OpenOCD Path Configuration 
Click "Global OpenOCD Path" to configure OpenOCD debugger, as 

shown in Figure 6-4. 

Figure 6-4 Global OpenOCD Path 

 

6.4 Global RISC-V Toolchains Paths Configuration 
Click "Global RISC-V Toolchains Paths" to configure the RISC-V MCU 

software toolchain, as shown in Figure 6-5. 

Figure 6-5 Global RISC-V Toolchains Paths 
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6.5 Global SEGGER J-Link Path Configuration 
Click "Global SEGGER J-Link Path" to configure ARM MCU debugger, 

as shown in Figure 6-6. 

Figure 6-6 Global SEGGER J-Link Path 
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7 Using GMD Software 

7.1 Create a New Project 

Click "File > New > C Project" on the menu bar or " " on the toolbar 
to open "New C Project" dialog box. 

Create a New Project 

 Select "Empty Project" in "Project type". 

 If you create a new ARM MCU software project, select "ARM Cross 
GCC" in "Toolchains". 

 if you create a new RISC-V MCU software project, select "RISC-V 
Cross GCC" in "Toolchains". 

 Select workspace, or use "Use default location" in "Location". 

 Enter the new project name in "Project name". 

 Click "Next", as shown in Figure 7-1. 

Figure 7-1 New C Project 
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Select Platforms and Configurations 

Select "Debug" and "Release", and click "Next", as shown in Figure 
7-2. 

Figure 7-2 Select Platforms and Configurations 

 

 

Select the Toolchain and Path 

If the default path "C:\GMD" is used, GMD software is configured by 
default and users do not need to configure the software toolchain; if you 
choose another installation path, re-configure the software toolchain. 

If it is an ARM MCU software project, select an ARM MCU software 
toolchain, as shown in Figure 7-3. 
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Figure 7-3 ARM MCU Toolchain and Path 

 
 

If it is a RISC-V MCU software project, select a RISC-V MCU software 
toolchain, as shown in Figure 7-4. 

Figure 7-4 RISC-V MCU Toolchain and Path 

 

7.2 Import Projects 
Click "File > Import" on the menu bar, select "General > Existing 

Projects into Workspace", and the "Import Projects" dialog box opens to 
import the existing projects, as shown in Figure 7-5. 
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Figure 7-5 Import Projects 

 
 
If the default path "C:\GMD" is used, GMD software is configured by 

default and users do not need to configure the software tool chain; if you 
choose another installation path, re-configure the software tool chain of the 
imported project. 

Right-click the project in "Project Explorer", click "Properties" to open 
"Properties" dialog box; click "C/C++ Build > Settings", select the 
"Toolchains" tab, and configure "Toolchain path" and "Build tools Path", as 
shown in Figure 7-6. 

In "Toolchain path", click "global"; if it is an ARM MCU software project, 
select "Global ARM Toolchains Paths"; if it is a RISC-V MCU software 
project, select "Global RISC-V Toolchains Paths". 

In "Build tools Path", click "global" and select "Global Build Tools 
Path". 
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Figure 7-6 Software Toolchain Configuration 

 

7.3 Project Configuration 

7.3.1 Tool Settings Configuration 

Right-click the project in "Project Explorer", and click "Properties" to 
open Properties dialog box; click "C/C++ Build > Settings", and select the 
"Tool Settings" tab; the ARM MCU "Tool Settings" configuration is shown in 
Figure 7-7, and the RISC-V MCU "Tool Settings" configuration is shown in 
Figure 7-8. 
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Figure 7-7 ARM MCU Tool Settings  

 
 

Figure 7-8 RISC-V MCU Tool Settings  
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7.3.2 Devices Configuration 

Configure "Devices > Device selection" of ARM MCU. 
Select "ARM Cortex M3 > ARMCM3" for ARM Cortex-M3 and select 

"ARM Cortex M1 > ARMCM1" for ARM Cortex-M3 device, as shown in 
Figure 7-9. 

Figure 7-9 Devices Selection  

 

7.4 Build Project 
After completing the project configuration and coding, build the project; 

click build button " ", or right-click the project to select "Build Project", as 
shown in Figure 7-10. 
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Figure 7-10 Build Project 

 

7.5 Download Project 
Use the download tool Programmer to download the software 

programming Binary file. 
Click "Run > Programmer" on the menu bar or " " on the toolbar to 

open Programmer, as shown in Figure 7-11. 

Figure 7-11 Download Project 
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7.6 Debug Projects 
Select "Run > Debug Configurations > GDB SEGGER J-Link 

Debugging" on the menu bar, right-click and select "New" to configure 
debugging, as shown in Figure 7-12. 

Figure 7-12 Debug Configurations 

 
 

After debugging configuration, click "Debug" to step through, as shown 
in Figure 7-13. 

Figure 7-13 Start to Debug 
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8 GMD Software Uninstallation 

Under GMD installation path, double-click "uninst.exe" to uninstall 
GMD software, as shown in Figure 8-1. 

Figure 8-1 GMD Uninstallation 
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