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1关于本手册 

1.1 手册内容 

本手册主要描述 MJB 软件的安装及操作，旨在帮助用户快速熟悉 MJB

软件的使用流程，提高设计效率。本手册中的软件界面截图和支持的产品列

表等信息均参考 1.0.0 版本，因软件版本升级，部分信息可能会略有差异，

具体以用户软件版本的信息为准。 

1.2 相关文档 

通过登录 Magic Jelly Bean Organization 网站

www.magicjellybean.com.cn 可下载、查看相关文档。 

1.3 术语、缩略语 

本手册中的相关术语、缩略语及相关释义，如表 1-1 所示。 

表 1-1 术语、缩略语 

术语、缩略语 全称 含义 

MJB Magic Jelly Bean 魔幻糖豆 

GUI Graphical User Interface 图形用户界面 

AI Artificial Intelligence 人工智能 

U2J USB to JTAG USB转JTAG 

ML Machine Learning 机器学习 

SoC System on Chip 片上系统 

MCU Microcontroller Unit 微控制器单元 

FPGA Field Programmable Gate Array 现场可编程门阵列 

GCC GNU Compiler Collection GNU编译器套件 

PC Personal Computer 个人计算机 

https://www.magicjellybean.com.cn/
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1.4 技术支持与反馈 

Magic Jelly Bean Organization 提供全方位技术支持，在使用过程中如

有任何疑问或建议，可直接与组织联系： 

网址：www.magicjellybean.com.cn 

E-mail：admin@magicjellybean.org 

https://www.magicjellybean.com.cn/
mailto:admin@magicjellybean.org
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2MJB 软件概述 

2.1 简介 

Magic Jelly Bean Organization（MJB）成立于 2021 年，是一个非盈利

组织，旨在嵌入式边缘端 AI 项目中，通过低成本的硬件开发平台和开放性的

软件平台，为 AI 兴趣爱好者、学术研究人员、电子发烧友等提供一个开源的

机器学习平台。其目的是通过一个共同的平台来创建一个由志同道合者组成

的开源社区，可以在机器学习和人工智能领域分享想法、项目和知识，共同

推进产业发展。 

MJB 软件是 Magic Jelly Bean Orgnization 专为 MJB 机器学习开发的集

成开发环境。MJB 软件直接集成 TensorFlow 和 TensorFlow Lite 框架，可以

自动生成 AI 硬件卷积运算加速器、MCU 驱动 AI 加速器的 C/C++代码以及带

有各种传感器输入的FPGA比特流，用户无需任何FPGA RTL或MCU C/C++

编程，即可将机器学习模型直接部署到 MJB Board 和 MJB Mini Board，实

现完全零编码。 

MJB 软件包括 MJB Board 和 MJB Mini Board 两个产品平台。通过

Camera、Audio、Accelerometer、HDMI Rx 等前端输入方式和 LED、UART、

HMDI Tx 等后端输出方式，可以直接将人物识别、汽车识别、性别识别、数

字识别、仪表识别、音频识别、动作识别、正弦曲线等机器学习模型部署到

MJB Board 和 MJB Mini Board 产品平台。 

MJB 软件支持 Windows 系统和 MacOS 系统，Windows MJB 软件界面

图，如图 2-1 所示。 
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图 2-1 Windows MJB 软件界面 

 

2.2 产品支持 

MJB 软件目前支持 MJB Mini Board 和 MJB Board 产品平台，具体的产

品类型及配置等，详见 Magic Jelly Bean 官方网站介绍：

www.magicjellybean.com.cn。 

注！ 

软件版本不同，支持的产品平台可能会略有差异，具体信息请参考所使用的软件版本。

https://www.magicjellybean.com.cn/
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3MJB 软件安装 

3.1 运行环境 

Windows：Win7/8/10（32 bit/64 bit） 

MacOS：MacOS 11.2.3 

3.2 软件下载 

Windows MJB 软件安装包 MJB_V1.0.0_win.exe 和 MacOS MJB 软件安

装包 MJB_V1.0.0_mac.pkg，可通过 Magic Jelly Bean Organization 官方网

站下载：www.magicjellybean.com.cn 

3.3 软件安装 
注！ 

 安装 MJB 软件前，建议关闭 360 或金山毒霸等杀毒软件； 

 软件安装路径尚不支持含有中文或空格的文件路径； 

 如需安装新版本 MJB 软件，建议卸载上个版本之后，再次安装； 

 可选择的安装部分如表 3-1 所示。 

表 3-1 Components to Install 

Components 描述 备注 

MJB GUI MJB软件图形用户界面 
MJB_V1.0.0_win.exe 

MJB_V1.0.0_mac.pkg 

U2J Windows USB to JTAG驱动软件 zadig-2.5.exe 

 

Windows MJB 软件安装流程 

安装 Windows MJB 软件，步骤如下： 

1. 双击安装包 MJB_V1.0.0_win.exe，进入 MJB 软件安装启动界面，请单

击“Next”，如图 3-1 所示。 

https://www.magicjellybean.com.cn/
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图 3-1 安装启动界面 

 
 

2. 阅读许可证协议，请单击“I Agree”，如图 3-2 所示。 

图 3-2 许可证协议 

 
 

3. 选择安装位置，请单击“Browse”选择安装位置。选择好安装位置后，

请单击“Install”，如图 3-3 所示。默认安装位置为 C:\MJB。 
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图 3-3 选择安装位置 

 
 

4. 安装进程，如图 3-4 所示。 

图 3-4 安装进程 

 
 

5. MJB 软件安装完成后，请选择是否安装 U2J 驱动软件。 

 如果选择安装，则请勾选“Please install USB driver for windows7/8/10”，

单击“Finish”，启动 Zadig-2.5.exe，安装 U2J 驱动软件。 

 如果不选择安装，则请不要勾选“Please install USB driver for 

windows7/8/10”，直接单击“Finish”，完成 MJB 软件安装，如图 3-5

所示。 

注！ 

 如果此处不选择安装 U2J 驱动软件，后续可在安装目录

MJB_V1.0.0\tools\programmer\driver\zadig-2.5.exe，选择单独安装。 
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 如果本地已安装过 U2J 驱动软件，建议不要勾选“Please install USB driver for 

windows7/8/10”重复安装。 

图 3-5 安装完成 

 

 

6. 如果选择勾选“Please install USB driver for windows7/8/10”，则打开

Zadig 安装 U2J 驱动软件，选择“Gowin U2J”、

“WinUSB(v6.1.7600.16385)”，单击“Install Driver”，如图 3-6 所示。 

图 3-6 安装 U2J 驱动 

 
注！ 

 U2J 驱动软件安装过程中，请务必保持 MJB Board 或 MJB Mini Board 与 PC 连接。 

 U2J 驱动软件安装过程中，MJB Board 或 MJB Mini Board 请不要连接 MJB_Camera、

MJB_MIC 或 MJB_Accelerometer 板卡。 

MacOS MJB 软件安装流程 

安装 MacOS MJB 软件，步骤如下： 

1. 双击安装包 MJB_V1.0.0_mac.pkg，进入 MJB 软件安装启动界面

“Introduction”，请单击“Continue”，如图 3-7 所示。 
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图 3-7 安装启动界面 

 
 

2. 阅读许可证协议，请单击“Continue”，如图 3-8 所示。 

图 3-8 许可证协议 

 
 

3. 选择安装位置，请单击“Change Install Location…”选择安装位置。选

择好安装位置后，请单击“Install”，如图 3-9 所示。 
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图 3-9 选择安装位置 

 
 

4. 安装进程，如图 3-10 所示。 

图 3-10 安装进程 

 
 

5. 安装完成后，如图 3-10 所示。 
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图 3-11 安装完成 

 
 

安装完成后，通过“Finder” > “Applications” > “Magic Jelly Bean.app”，

即可打开 MJB 软件。 

注！ 

MacOS 系统自带 USB 驱动，无需手动安装。 
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4MJB 软件用户界面 
以 Windows MJB 软件为例，介绍 MJB 软件用户界面。 

MJB 软件用户界面，如图 4-1 所示，主要分为标题栏、菜单栏、工具栏、

工程管理区（Project Explorer）、源文件编辑区和信息输出区。 

图 4-1 软件用户界面 

 

 

① 标题栏 ② 菜单栏 

③ 工具栏 
④ 工程管

理区 

⑤ 源文件编辑

区 

⑥ 信息输

出区 
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4.1 标题栏 

主要显示当前工程打开的文件路径及名称。 

4.2 菜单栏 

主要提供一些常用菜单以及工程所需的启动工具，包括 File、Edit、Project、

Tools、Views 和 Help 选项，详情如下。 

4.2.1 File 菜单栏 

 New…：新建工程 

 Open…：打开工程 

 Save：保存工程中的文件 

 Save As…：文件另存为 

 Save All：保存所有文件 

 Close：关闭当前工程打开的文件 

 Close Start Page：关闭 Start Page 

 Close Current Project：关闭当前工程 

 Recent Files：最近打开的文件，可重新进行打开 

 Recent Projects：最近打开过的工程，可重新选择打开 

 Exit：软件退出 

4.2.2 Edit 菜单栏 

 Undo：撤销 

 Redo：重做 

 Cut：剪切 

 Copy：复制 

 Paste：粘贴； 

 Select All：选择全部 

 Find…：查找关键词 

 Replace…：替换关键词 

4.2.3 Project 菜单栏 

 Run…：运行当前工程 

 Configuration…：配置当前工程的输入、输出调试信息 

 Model Viewer：查看当前工程的机器学习模型 

4.2.4 Tools 菜单栏 

 Start Page：开始页 
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 Google Colaboratory：用户模型训练 

 Options…：用户可在此处配置外部文本编辑器 

4.2.5 Views 菜单栏 

 Full Screen：全屏显示 

 Tool Bars：对工具栏各菜单选项的选择 

 Panels：对界面中各区域显示模块的选择 

4.2.6 Help 菜单栏 

 About Magic Jelly Bean：软件版本信息 

4.3 工具栏 

提供一些常用功能的快速访问入口，按钮从左至右依次为： 

 “ ”：新建工程（New Project） 

 “ ”：打开工程（Open Project） 

 “ ”：保存文件（Save） 

 “ ”：保存所有文件（Save All） 

 “ ”：撤销（Undo） 

 “ ”：重做（Redo） 

 “ ”：剪切（Cut） 

 “ ”：复制（Copy） 

 “ ”：粘贴（Paste） 

 “ ”：查找（Find） 

 “ ”：运行当前工程 

 “ ”：配置当前工程的输入、输出调试信息 

 “ ”：查看当前工程的机器学习模型 

4.4 工程管理区（Project Explorer） 

提供工程及其相关文件的管理和显示功能，包括 MCU C/C++代码、机器

学习模型（.tflite）、机器学习模型参数（tflite_model_parameters.h）。 

4.5 源文件编辑区 

提供基本的文件编辑、查看及选中关键词高亮功能。 

在 File 窗口新建或打开的工程文件、运行后生成的机器学习模型参数

（tflite_model_parameters.h）文件等均可显示在文本编辑区，另外“Start   

Page”同样会显示在文本编辑区。 
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当前工程中的文件均为只读文件，不可编辑修改。 

单击“File”菜单栏中“Close”选项或文本编辑区当前显示文件名右

侧“ ”，会关闭文本编辑区内当前显示的文件。 

打开某个文件后，可通过快捷键 Ctrl+F 或单击工具栏中的 Find 按钮来

打开“Find”选项，如图 4-2 所示。 

图 4-2 Find 选项 

 

4.6 信息输出区 

显示软件在运行过程中的处理信息，如图 4-3 所示。 

在 Output 窗口单击右键，选择“Clear”，可清空所有页的信息。 

图 4-3 信息输出界面 
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5MJB 软件使用 

以 Windows MJB 软件为例，介绍 MJB 软件使用方法。 

MJB 软件支持界面模式运行，以 Windows10 版本 MJB 软件界面运行为

例，介绍软件的使用方法。 

5.1 新建工程 

1. 单击“File > New…”，打开“New”对话框，如图 5-1 所示。 

图 5-1 新建工程 

 

注！ 

亦可通过以下三种方式打开“New”对话框： 

 使用快捷键 Ctrl+N； 

 单击工具栏上“New File or Project”图标； 

 单击 Start Page 界面上“Quick Start > New Project”。  

2. 打开“New”对话框后,请选择“MJB Project”，单击“OK”，打开

“Project Name”窗口，如图 5-2 所示。 



5 MJB 软件使用  5.1 新建工程 

 

MUG100-1.0 17(30) 

 

图 5-2 新建工程名称和路径                                                                                                      

 
 

3. 创建工程名称和路径，如图 5-2 所示： 

a) 在“Name”文本框中输入工程名称。 

b) 单击“ ”选择工程路径。 

注！ 

 Windows 和 Linux 下的文件路径长度均有限制，在路径下存在文件长度超出系统限制

的情况下，删除或者拷贝路径都会失败； 

 与 Linux 不同，在 Windows 中路径分隔符为“\”，如 E:\MJB。 

4. 单击“Next”，打开“Project Type”窗口，如图 5-3 所示。 

 在“Board Type”下拉列表中选择开发板类型，例如 MJB STD Board

和 MJB Mini Board； 

 在“Project Type”下拉列表中选择项目类型，例如 Car Detection、

Clock Detection、Digit Detection、Gender Detection、Hello World、

Magic Wand、Micro Speech 和 Person Detection； 

 在“Frontend Input”下拉列表中选择前端输入方式，例如 Camera、

HDMI、Accelerometer 和 Microphone； 

 在“Backend Output”栏中选择后端输出方式，例如 LED、HDMI

和 UART。   
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图 5-3 设置项目类型 

 

 

其中，开发板类型、项目类型、前端输入方式和后端输出方式关联关系，

如表 5-1 所示。 

表 5-1 项目类型关联关系 

Board Type Project Type Frontend Input Backend Output 

MJB Mini 
Board 

Car Detection Camera 
LED 

UART 

Clock Detection Camera 
LED 

UART 

Digit Detection Camera 
LED 

UART 

Gender Detection Camera 
LED 

UART 

Hello World - 
LED 

UART 

Magic Wand Accelerometer 
LED 

UART 

Person Detection Camera 
LED 

UART 

MJB Board 

Car Detection 

Camera LED 

HDMI 
HDMI 

UART 

Clock Detection 
Camera LED 

HDMI HDMI 
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Board Type Project Type Frontend Input Backend Output 

UART 

Digit Detection 

Camera LED 

HDMI HDMI 

- UART 

Gender Detection 

Camera LED 

HDMI 
HDMI 

UART 

Hello World - 
LED 

UART 

Magic Wand Accelerometer 
LED 

UART 

Micro Speech Microphone 
LED 

UART 

Person Detection 

Camera LED 

HDMI 
HDMI 

UART 

 

5. 单击“Next”，在 Summary 窗格中核对新建工程的工程信息及项目信息，

如图 5-4 所示。 

图 5-4 工程信息 

 
 

6. 单击“Finish”，工程创建完成。 
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5.2 打开工程 

用户可直接通过 MJB 软件界面打开已创建的 MJB 软件工程，有以下四

种方式打开工程： 

菜单栏打开 

1. 菜单栏中，选择“File> Open …”打开“Open File”对话框，如图 5-5

所示。 

注！ 

亦可通过单击工具栏上的“ ”图标，打开“Open File or Project”对话框。 

图 5-5 打开工程 

 
 

2. 选择“Open File >工程文件（*.mjb）”，单击“Open”，打开工程。 

Start Page 打开 

1. 在“Start Page”页面中，单击“ ”，打开“Open Project”对话框。 

2. 点击“Open”，打开工程。 

Recent Projects 打开 

菜单栏中，单击“File > Recent Projects”，选择需打开的工程。 

注！ 

 亦可在“Start Page >Recent Projects”列表中，选择需打开的工程； 

 “Recent Projects”为最近打开过的工程列表； 

 若该工程已被删除，会弹出“Open Project”提示框。 

工程文件打开 

在本地找到建立的工程，在工程中找到工程文件*.mjb，双击工程文件，

就会自动识别 MJB 软件打开工程。 
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5.3 查看工程 

新建或打开工程后，可在工程管理区对 MCU C/C++代码、机器学习

模型（.tflite）、机器学习模型参数（tflite_model_parameters.h）及相关文件

等进行查看，如图 5-6 所示。 

工程管理区主要包含以下信息： 

 MCU C/C++代码文件； 

 机器学习模型（.tflite）； 

 机器学习模型参数（tflite_model_parameters.h）。 

图 5-6 工程文件窗口 

 
注！ 

亦可单击“ ”，打开查看当前工程的机器学习模型（.tflite）。 

5.3.1 查看机器学习模型 

可在工程管理区内，双击机器学习模型（.tflite），通过 Model Viewer

（Netron）打开查看当前工程的机器学习模型，如 hello_world 机器学习模

型如图 5-7 所示。 
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图 5-7 查看机器学习模型 

 

5.3.2 查看机器学习模型参数 

运行当前工程后，生成机器学习模型参数（tflite_model_parameters.h），

可在工程管理区内，双击 tflite_model_parameters.h，打开查看当前工程的

机器学习模型参数，如 hello_world 机器学习模型参数如图 5-8 所示。 

图 5-8 查看机器学习模型参数 
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5.3.3 修改工程配置  

菜单栏中，选择“Project > Configuration…”，打开“Project Configuration”

对话框，如图 5-9 所示。 

注！ 

亦可通过单击工具栏上的“ ”图标，打开“Project Configuration”对话框。 

图 5-9 修改工程配置 

 
 

可配置的工程属性包含“Enable Input Debug”和“Enable Output Debug”

属性： 

 Enable Input Debug：打印输出“前端输入调试信息”； 

 Enable Output Debug：打印输出“后端输出调试信息”。 

前端输入调试信息和后端输出调试信息，请连接串口，通过串口打印输

出。 

5.4 运行和下载工程 

菜单栏中，单击“Project > Run”，运行和下载工程，如图 5-10 所示。 

注！ 

亦可通过单击工具栏上的“ ”图标，运行和下载工程。 

图 5-10 运行和下载工程 
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5.5 退出软件 

通过以下方式，退出 MJB 软件： 

1. 单击“File > Exit”选项； 

2. 单击软件界面右上角图标“ ”。 
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6MJB 软件项目介绍 

6.1 Car Detection 

用于目标为汽车的检测识别，检测识别汽车存在和不存在，如图 6-1 所

示。 

前端输入方式： 

 Camera 

 HDMI 

后端输出方式： 

 LED 

 UART 

 HDMI 

图 6-1 Car Detection 

Camera Board
Image Provider

Captures ima ge data  from the ca mera/hdmi rx

ML Convolution Accelerator
Runs the M L m odel

Detection responder
Tak es action ba sed on whether a c ar i s 

detected

Model
Tra ined to cla ssify pres ence 

or absence of a c ar

LED/UART/HDMI 
Tx HDMI Device

MJB Board/MJB Mini Board

HDMI Rx

 

注！ 

仅 MJB Board 支持 HDMI Rx 和 HDMI Tx。 

6.2 Clock Detection 

用于目标为模拟仪表盘“0~59”的检测识别，检测识别模拟仪表盘“0~59”，

如图 6-2 所示。 

前端输入方式： 



6 MJB 软件项目介绍  6.3 Digit Detection 

 

MUG100-1.0 26(30) 

 

 Camera 

 HDMI 

后端输出方式： 

 LED 

 UART 

 HDMI 

图 6-2 Clock Detection 

Camera Board
Image Provider

Captures ima ge data  from the ca mera/hdmi rx

ML Convolution Accelerator
Runs the M L m odel

Detection responder
Tak es action ba sed on which dig it of ana log 

meter  0~59 is detec ted

Model
Tra ined to cla ssify a nalog  

meter  0~59 

LED/UART/HDMI 
Tx HDMI Device

MJB Board/MJB Mini Board

HDMI Rx

 
注！ 

仅 MJB Board 支持 HDMI Rx 和 HDMI Tx。 

6.3 Digit Detection 

用于目标为数字“0~9”的检测识别，检测识别数字“0~9”，如图 6-3

所示。 

前端输入方式： 

 Camera 

 HDMI 

后端输出方式： 

 LED 

 UART 

 HDMI 
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图 6-3 Digit Detection 

Camera Board
Image Provider

Captures ima ge data  from the ca mera/hdmi rx

ML Convolution Accelerator
Runs the M L m odel

Detection responder
Tak es action ba sed on which dig it of 0~9 is 

detected

Model
Tra ined to cla ssify dig it 

 0~9 

LED/UART/HDMI 
Tx HDMI Device

MJB Board/MJB Mini Board

HDMI Rx

 

注！ 

仅 MJB Board 支持 HDMI Rx 和 HDMI Tx。 

6.4 Gender Detection 

用于目标为性别的检测识别，检测识别女性、男性以及 Unknown，如图

6-4 所示。 

前端输入方式： 

 Camera 

 HDMI 

后端输出方式： 

 LED 

 UART 

 HDMI 

图 6-4 Gender Detection 

Camera Board
Image Provider

Captures ima ge data  from the ca mera/hdmi rx

ML Convolution Accelerator
Runs the M L m odel

Detection responder
Tak es action ba sed on whether fema le or ma le 

is detec ted

Model
Tra ined to cla ssify fem al e or 

ma le of gender

LED/UART/HDMI 
Tx HDMI Device

MJB Board/MJB Mini Board

HDMI Rx

 
注！ 

仅 MJB Board 支持 HDMI Rx 和 HDMI Tx。 
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6.5 Person Detection 

用于目标为人物的检测识别，检测识别人物存在和不存在，如图 6-5 所

示。 

前端输入方式： 

 Camera 

 HDMI 

后端输出方式： 

 LED 

 UART 

 HDMI 

图 6-5 Person Detection 

Camera Board
Image Provider

Captures ima ge data  from the ca mera/hdmi rx

ML Convolution Accelerator
Runs the M L m odel

Detection responder
Tak es action ba sed on whether a person is 

detected

Model
Tra ined to cla ssify pres ence 

or absence of a person

LED/UART/HDMI 
Tx HDMI Device

MJB Board/MJB Mini Board

HDMI Rx

 
注！  

仅 MJB Board 支持 HDMI Rx 和 HDMI Tx。 

6.6 Hello World 

正弦曲线 Y=sin(X)，给定输入 X，预测 Y，如图 6-6 所示。 

前端输入方式： 

 无 

后端输出方式： 

 LED 

 UART 
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图 6-6 Hello World 

Preprocessing
T ra nsforms  input to be  compa ti bl e with m odel

ML Convolution Accelerator
Runs the  M L m odel

Postprocessing
Interprets the  m odel’s output a nd mak es 

dec isions

Model
Tra ined to mak e predictions 

on data

LED/UART

MJB Board/MJB Mini Board

Input Data
00001110

Output handling
Us es devi ce capa bilities to respond to 

predic ti on

 

6.7 Magic Wand 

用于目标为手势和动作的检测识别，检测识别手势动作 Wing、Ring、

Slope 以及 Unknown，如图 6-7 所示。 

前端输入方式： 

 Accelerometer 

后端输出方式： 

 LED 

 UART 

图 6-7 Magic Wand 

Accelerometer 
Board

Accelerometer handler
Captures acc el erometer da ta

ML Convolution Accelerator
Runs the M L m odel

Gesture predictor
Determi nes i f a v ali d gesture ha s been 

detected

Model
Tra ined to cla ssify three 

g estures and  unknown 

LED/UART

MJB Board/MJB Mini Board

Output handler
Tak es action ba sed on which g esture was 

detected
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6.8 Micro Speech 

用于目标为语音和声音的音频检测识别，检测识别音频 Silence、Yes、

No 以及 Unknown，如图 6-8 所示。 

前端输入方式： 

 Microphone 

后端输出方式： 

 LED 

 UART 

图 6-8 Micro Speech 

Microphone Board
Audio provider

Captures audio sa mples from microphone

Feature provider
Conv erts ra w audio da ta  into spectrog rams

ML Convolution Accelerator
Runs the M L m odel

Model
Tra ined to cla ssify  y es , no, 

sil ence a nd unknown

LED/UART

MJB Board/MJB Mini Board

Command recognizer
Us es i nference output to dec ide if comma nd 

was hea rd

Command responder
Tak es action ba sed on which com mand wa s 

hea rd
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